1999 whizzer clutch doesn't disengage

Discussion in 'Whizzer Motorized Bicycles' started by john hamilton, Jul 8, 2008.

  1. john hamilton

    john hamilton New Member

    I have a 1999 whizzer I bought last fall. When I engage the clutch handle the belt still seems engaged. I had a dealer look at it and he said that if he adjusts the belt to much it won't pull the bike up hills. He said thats why they went to the auto clutches. I guess I was expecting the clutch to work like on my former motorcycle. Is this a common problem? I enjoy my Whizzer but have only ridden it about 4 times because I felt I was still being pulled along even when the clutch was engaged. The local dealer explanation seems to make sense and he adjusted the idle speed, etc so it doesn't die when I come to a stop sign. I feel a lot more confident riding it now. I am going to put a front hitch on my chevy ext cab so I can mount a front dirt bike carrier for my whizzer. This way I can still pull my Airstream camper and carry a boat and fishing gear in the back of the truck. John

  2. NunyaBidness

    NunyaBidness Member

    hey John
    welcome to the site
    I'm not up on the Whizzer but I'm sure someone will be along to help you or at least point you in the right direction
  3. graucho

    graucho Active Member

    Hi John. Welcome to MBc!

    If you search and are unable to find your answers, don't hesitate to post your question. Someone will steer you to a link, or reply to your question. Were here for each other! Enjoy! :grin:
    You may have seen this, but here's a great MBc starter "link" to get you motoring.