Engine Trouble 38cc Baby Mosquito engine

Discussion in '2-Stroke Engines' started by Roy Bryant, Sep 30, 2013.

  1. Roy Bryant

    Roy Bryant New Member

    I just purchased a Legnano bicycle with a 38cc Baby Mosquito engine. I love it but do not know much about it yet. After cleaning points it started up nicely. I put in a new spark plug. If gas was not shut off, gas would flow air intake end of Carburator.
    It seemed to run well until it warmed up then it would sound like it was skipping or not running smoothly. I put a new needle valve and float in the carburator and it seemed to correct the gas overflow problem but it still begins running poorly when it is warmed up.

    I am trying to figure out what is happening to cause it to run poorly. Coil? Magneto? electrical?
    I have a few questions for anyone who may know something about this engine.
     

  2. HeadSmess

    HeadSmess Well-Known Member

    sounds old, show pics.


    could be anything.

    coil is starting to overheat and shorts out internally.

    condensor on points, ditto.

    points themselves, hmmms. worth another clean annd retweak.

    rings, cylinder. what type of bore? if its cast iron, could just need a re hone.

    how are the rings, if theyre worn, good luck finding new ones :( could be made... or piston changed etc.

    and, if its a chrome plated alloy cylinder, its the chrome plating...
     
  3. Roy Bryant

    Roy Bryant New Member

    Thanks for you help. I found chafed wires on the coil wires and put on some shrink tubing, it runs much better, but now seems to totally stop running when it warms up. I pulled the plug wire and still have spark, and gas looks good. I dont know whats up.. Any Ideas?
     
Loading...