After adding SBP exhaust !SMOKE!

Discussion in 'Performance Mods' started by gboybst578, Dec 3, 2010.

  1. gboybst578

    gboybst578 New Member

    Hey everyone maybe someone here can help me after adding my SBP exhaust i have losts of white smoke coming out that i didnt used to have.

    is this do to buildup in the engine that might just be burning away?

    how is it running to rich when i thought the exhaust supposed to make it run a little lean?

    seems like the bike idles faster then usual after the pipe was on also.

    should i pull the carb and change the needle position up one?

    or let it run for a couple miles and see if it clears up?

    Thanks Everyone, Garrett

  2. AussieSteve

    AussieSteve Active Member

    White smoke?
    If everything else looks OK, run it for a while and see if it stops smoking. Might just be oil or paint or something burning off the pipe.

    Regarding the air/fuel mixture, if it's idling higher than before, it might be running leaner than previously. Check the plug colour.
    Last edited: Dec 3, 2010
  3. gboybst578

    gboybst578 New Member

    after posting this i decided to take it for a ride while moving everything around i tightened the throttle cable to tight and it was having it open a quarter of the way all the time so i fixed that runs like a champ now really huge amout of power gain.

    here is a pic please dont give me a violation if i dont post this pic right still learning.

    i love the way i ran the pipe almost follow the curve of the bike. solid as heck.

    - thanks for the help

    Attached Files:

  4. AussieSteve

    AussieSteve Active Member

    Looks good. It does fit your bike well.

    Glad the smoke problem went away.
    With the throttle cable - leave about 2-3mm slack in the cable to allow for moving the handlebars left to right, or the idle might increase when doing a tight turn - more than a little disconcerting at times.

    (The powers-that-be are pretty decent and wouldn't give you an infraction for not posting a pic correctly. At worst, you'd get advice on how to do it right. As things stand, you've done well - a well-chosen title and you added a thumbnail rather than an inline pic.)
  5. gboybst578

    gboybst578 New Member

    i got a infraction for posting my first pic on my first post in the introduction section for using the wrong img tag or something if i get one more i get banned for like 10 days or something. but its cool as long as i am doing it right now then its cool.
  6. HeadSmess

    HeadSmess Well-Known Member

    what was the pic of? :lol:
  7. gboybst578

    gboybst578 New Member

    just a picture of my bike that i just build first one it was in the introduction section.