bad vibration,

Discussion in '2-Stroke Engines' started by japman, Sep 9, 2011.

  1. japman

    japman New Member

    hi my name is japman, i have a huffy panama jack bicycle,with a 80cc engine on it.i have such a bad vibration in the bike,its terrible.ive tried rubber motor mounts, does anyone have any ideas? please help!!!!!!!!!!!!

  2. PatrickW

    PatrickW Staff Member

    Welcome to MBc, Japman. I would suggest reading everything you can, and use our search function. Post a question in 2-Stroke Engines, and be sure to include all of the info you can about your engine and engine kit, how it is mounted, and pictures if you can.
  3. Buck up bart..BUCK UP..Should have bought cha a 49 or maybe switch to electric?
  4. Fabian

    Fabian Well-Known Member

    These engines can be quite strange. Sometimes my engine runs reasonably smooth and the next day it runs with a heck of lot more vibration. Nothing has changed except for the passing of 24 hours.
    Pull the bike out for a ride a day or two later and it runs more like it used to, before getting the odd day here and there where it vibrates heavily.

    I still have no idea why this happens and it's completely random in it's nature.
    Some days it runs exceptionally smooth which makes the situation even more intriguing.
  5. Samdallas214

    Samdallas214 Member

    mine vibrated real bad in my case it was 3 broken clutch springs could it be that simple
    I replaced them and that fixed the problem, when the spring broke there was no more the 50 miles on the new engine, replaced them and runs great now.
  6. jaguar

    jaguar Well-Known Member

    try using a wrist pin that is lighter (with a larger diameter hole in its center). That works good for the Grubee engine. Measure yours and ask around at places like Treatland and 1977mopeds
  7. HeadSmess

    HeadSmess Well-Known Member

    get rid of the rubber strips under the motor mounts.