Clutch issue: small ball bearings loose in clutch

Discussion in 'Frame Mounted Engines' started by Elmstreetmotorized, Apr 25, 2009.

  1. Elmstreetmotorized

    Elmstreetmotorized New Member

    I am new to the site, I did a little searching but did t find much on this. So I apologize in advance if this has been covered and I missed it.
    I have a new 66cc china from boygofast. Around the 2nd or 3rd start I noticed some noise from the clutch. As if something was loose inside and moving around. When I pulled the cover off I found multiple small metal balls loose inside. They appear to me to be the balls from the inside of a bearing. Is this normal? They don't appear to be serving any purpose other then causing damage.
    Any help would be appreciated

  2. Skyliner70cc

    Skyliner70cc Active Member

    no, not normal. Happy repairs. Don't bother wasting even a minute of your time, BGF doesn't provide any service after the sale.
  3. Elmstreetmotorized

    Elmstreetmotorized New Member

    Ok a it's not normal. I took them out and the clutch seems to work it's just noisy at idle seeds.
    Any ideas where they may have come from? Maybe a part that broke that I can replace.
  4. BoltsMissing

    BoltsMissing Active Member

    In Search function, type in keywords "clutch bearings" and select to look in 2-stroke section, post with pictures shows up the following thread
    These bearings are a PItA.
    I doubt they are ever greased at engine factory, but there are 3 tiny holes where you might be able to force feed some hi temp grease or molly grease during build phase.
  5. jayman68

    jayman68 New Member

    Need clutch help please

    Ok,took clutch cover off keep ajusting the flower nut,,but clutch still dont grab,,wheel spins freely,,can it be the bearing arm