Engine Trouble Engine rpms scream at 50% throttle

Discussion in '2-Stroke Engines' started by Cyclonestrem, Apr 22, 2013.

  1. Cyclonestrem

    Cyclonestrem New Member

    Hey guys how's it going I had a question regarding my two stroke robins ec04er engine the one without a clutch and it has a big shaft. I had it on my bike as a friction drive and it was great then I stopped using it for about a month and it also fell but only hit the pull starts assembly nothing hit the engine block. Now when I turn it on it idles fine but as soon as I appy throttle once it hits around 40-50% throttle the engine is screaming a high revs. It no longer has a smooth power band and I was wondering what might be causing this prob I'd appreciate any info thanks guys.
    Last edited: Apr 22, 2013

  2. BigBlue

    BigBlue Active Member

    Possible air leak? Carburetor loose? Cylinder loose? Air filter assemble loose? Or did you remove the throttle cable and maybe it didn't seat properly when you re-installed - it happened to me couple times on my EC04er. I replaced the generator carburetor with a pocket bike carburetor. Did you empty the old fuel and fill with a fresh mix of 50:1? If you left the old fuel, it may have separated?

    Good Luck,

    AKA: BigBlue
  3. Cyclonestrem

    Cyclonestrem New Member

    I don't think there's any leaks I took it apart and the gaskets have no rips or tears and I tightened all the bolts down I don't have a exhaust gasket and theres a gap but I don't think that'll do it or would it? Also what carb did you purchase I was looking into that but idk what type or size would fit thanks for all the help
  4. BigBlue

    BigBlue Active Member