engine runs for a while then bogs out

Discussion in '2-Stroke Engines' started by Canon, Jul 30, 2010.

  1. Canon

    Canon New Member

    I dont know what the problem is. It will run for awhile, then i start gaining speed and it bogs down and dies. The only thing that seems to help is having the choke all the way up? this makes no sense to me, I took the carb apart and couldnt find any problems. Any advice would be appreciated.

  2. Hawaii_Ed

    Hawaii_Ed Member

    sounds like an air leak. Is the head all the way tight? Check the carb and manifold too.
  3. a/c man

    a/c man Member

    Sounds to me like a bad fuel flow:
    Clogged vent in gas cap
    Slow flowing fuel to carb :partially clogged restricted fuel filter in tank
    Gas cock at tank crud inside (passages are tiny)
    External fuel filter slow flowing
    Did you ever listen to a weed whacker just before it runs out of gas?
    It revs up like mad and dies.
    I bet after you let it sit a while gas refills your float bowl and it runs again and does the same routine...
    Just a thought
  4. mrbg

    mrbg Member

    On my 2nd bike it started bogging down at wot I bought a couple of jets from sick bike parts and put the clip on 2nd notch from the top bike ran great! Now its doing the same thing I pulled the head and noticed cylinder head studs were loose but I snugged them up put the head back on, and it's still bogging down at WOT its gotta be an airleak. I guess I'll have to get some carb cleaner and fire it up and spray at the base gasket and intake manifold and see where the airleak is,kid at the bike shop where I bought the kit says the cleaner maybe hard on the seals but I can't think of another way to find the leak? Anyone got another way
  5. crassius

    crassius Well-Known Member

    I just spray it with water & listen for any difference
  6. mrbg

    mrbg Member