Carby GAH! carb problems!

Discussion in '2-Stroke Engines' started by speedracer831, Oct 7, 2009.

  1. speedracer831

    speedracer831 Member

    so, about 2 weeks ago i had my bike completely built and was riding all the time. i installed the racing carb from zoom and a sbp expansion chamber pipe. it all worked great- crazy torque and acceleration, great top speed (about 33) but i tried tuning the racing carb and screwed it up. it just bogs down at like 15mph and wont go faster, no matter what amount of rotations i put the screw in. makes no sense... anyway, im currently using the stock carb but would love to go back to the racing carb. anyone know the setting they have their screws at, and how well it works for you? thanks,

    jonah
     

  2. biketec

    biketec Member

    Did you cut the vent hose in half where its connected for some odd Chinese reason? if not you need to and you should be good! If you have done this start by going in till you feel resistance ( careful as you don't wanna bend or scar ) then 3 turns out go from there make very small adjustments kinda like this ( / ) umm if that doesn't work check for leaks with WD or carb cleaner if you need more help just ask me and I will try to walk you through it.
     
  3. speedracer831

    speedracer831 Member

    thanks so much, but what do you mean cut the vent tube in half?
     
  4. biketec

    biketec Member

    the red/pink tube from the bottom to the top ones a vent the others a drain but if left connected it will fill up and siphon and run like an 80yo lady with an oxygen bottle.
     
  5. speedracer831

    speedracer831 Member

    oh. that tube i have zip-tied to my frame to keep it outta the way. is that ok? it usually is filled up about an inch with fuel
     
  6. biketec

    biketec Member

    CUT IT your done!
     
  7. speedracer831

    speedracer831 Member

    well thanks, that helps a ton you just solved all my problems!
     
Loading...