Hi gang I'm 2go and new to this forum.

Discussion in 'Introduce Yourself' started by 2go, Feb 8, 2015.

  1. 2go

    2go New Member

    Not having used a forum before, and lacking a lot of savvy, I'm a bit challenged. I will try looking around at previous threads to see if any address my clutch problems. I look forward to learning more and hopefully, being able to participate in some constructively...2go

  2. wheelbender6

    wheelbender6 Well-Known Member

    Welcome to the forum. Your in the right place to get help with that clutch.
  3. 2go

    2go New Member

    Thanks Wheelbender6

    I hope that I'm doing this right. Do you have to go through the formality of the image verification every time you reply?
  4. troyg

    troyg Member

    It's been a while, but think it's just for the first 10 or so posts to stymie bots.Have fun.
  5. 2go

    2go New Member

    Thank you Troyg,
  6. 2go

    2go New Member

    I have a reoccurring problem with a centrifugal cutch burning its shoes or stretching it's springs. I have re-lined the shoes and been through 3 sets of springs on a 3 shoe clutch on a 49 cc hua sheng motor kit. Any suggestions as to what to check?
  7. chet182

    chet182 New Member

    Hi 2go, I'm experiencing the same problem on the same engine. Frustrated as all hell, I've been through at least 4 clutches, ugh! I called a brake specialist and he said to try of all things leather! Ya know cut to dimensions and expoxy it to the clutch. I'm also looking into ceramic pads but haven't found anything yet. Could be a consideration on your part, too. Anyway, I am curious if you had the same problem i did with my kit, it seemed like the very first clutch that came with the engine lasted at least 300 miles and the ones I bought after that were crap. Please share with me, as I will with you if you find anything. Good luck!