Hmm..this is odd

Discussion in '2-Stroke Engines' started by Werdna, Mar 2, 2007.

  1. Werdna

    Werdna Guest

    I'm a little confused with the performance of my bike. Some days it seems like my bike has a huge amount of power and it feels great! But, then somtimes my bike has like absolutly no power at all! It doesn't seem like it has to do with the weather or the variance of conditions. Has anyone else had these problems? Does it have to do with the carb? What can I do to stop it!!!!

    Thanks!
     

  2. srdavo

    srdavo Active Member

    hmmmm.....? that's a good question.
    1st... a new sparkplug never hurts anything :D
    is the screen in your fuel tank partially plugged?
    somebody suggested once on here that the petcock might not be fully open in the obvious position. I can't seem to find a link to it. anyway...the author suggested the lever might need to be a little left or right of center. you can find out the best flow by removing the petcock and blowing thru it. while you have it apart...you can check your screen.....then, when you put it back together, I suggest putting in a small inline fuel filter.
    anybody else have any :idea:
    keep us posted.

    btw...did you ever find a bigger rear sprocket?
     
  3. bamabikeguy

    bamabikeguy Active Member

    Use FRESH gas/mix - I never believed that one, till I used some old gas last month.

    Buildup on the EXHAUST/MUFFLER- but that would be a constant problem, not a "sometime occurance".
     
  4. Werdna

    Werdna Guest

    Thanks! I do have old gas (about 3 months), do you only put in like part of a tank at a time? I'll check the screen also. A got an inline fuel filter awhile ago but it didn't seem like the engine was drawing the gas through it well enough. That was the first time I ever road it and I haven't tried the filter again. Probably should try it again!! I got my from a auto store, I don't know what it was for but it was really small. Is there a specific kind that works really well?

    Thanks!
     
  5. gone_fishin

    gone_fishin Guest

    gas in your tank or stored in a can is still old gas, and it could be the cause of your problem, no doubt.

    i now know how much fuel i use in a month, about 1.5 gallons...so i've taken to buying exactly that much at beginning of every month and premixing in my gas-can.