loss of power at 28 mph

Discussion in '2-Stroke Engines' started by akillerbluesky, Jul 10, 2008.

  1. akillerbluesky

    akillerbluesky New Member

    this morning i was riding and i got up to about 28-30 mph and i lost power. my bike slowed down to about 18mph. i will say that i did change my exhaust gasket last night, and on my carb the fuel/air mix screw fell out and i have screw that fits but when i ride the vibrations twist it out so i wired it on. does any one know what might be up with the loss of power?
     

  2. JemmaUK

    JemmaUK Guest

    Hi,

    It might be the exhaust gasket has sprung a leak - but I would be more looking towards the carb mixture as being the problem. If you havent replaced the missing mixture screw with something the right size etc, which could be the case when you say you need to wire it... its likely that the fuel/air mix is a problem..

    hope that helps

    Jemma xx
     
  3. BSA

    BSA Guest

    If you have a happy time engine there is no mixture screw, it is an idle adjust screw. It sounds to me like the screw has fell out and caused an air leak thus reducing performance. if you continue riding like that you may damage your engine as the mixture would be way to lean, so I'd just get a new screw and then run it again.

    BSA
     
  4. Skyliner70cc

    Skyliner70cc Active Member

    28mph is just past the speed of sound. When you were breaking through the sonic barrier, the sonic boom must have done some engine damage. Its only an uneducated guess on my part.
     
  5. jared3377

    jared3377 Member

    HAhahahahahh! "Sonic barrier"--now that's good (I think Skyliner's right, too!!!:shock:).

    Actually, mine does that too, and I'm *thinking* that it's intake since it's been doing it ever since I drilled a couple of holes in my muffler's baffle (2 strokes need back pressure).

    I, however, don't mind because I'm not lookin' for top speed, just more acceleration and climbing power. BUT, if you're looking for top speed, then I would suggest (and posters can [should] correct me if I'm wrong since I'm still new at this...
     
  6. badmoon

    badmoon Member

    when the whether is wet outdoor its not good for running fast . check your needle c-clip and put it to the 3 stage down try sonething like that clean your muffler INTERIOR and carb. The magneto can be the prob if its too high but i thinks it your muffler and check your sparkplug if its clean.
     
    Last edited: Jul 14, 2008
  7. akillerbluesky

    akillerbluesky New Member

    whats the best way to clean the muffler?
     
    Last edited by a moderator: Jul 19, 2008
  8. akillerbluesky

    akillerbluesky New Member

    ok cool i will try that. another question do you know of any links on fine tuning the engine? i want this running the beat that it can.
     
  9. BSA

    BSA Guest

    O.K way too much off topic on this thread, I'm cleaning it up.
    the answe to the question on this thread is re jetting the carb. Do a search on it.

    BSA
     
    Last edited by a moderator: Jul 19, 2008
  10. HeHeHe !!!



    bob
     
Loading...
Similar Threads -
  1. zippinaround
    Replies:
    17
    Views:
    177
  2. LeTweek

    Engine Trouble Power loss

    Replies:
    4
    Views:
    745
  3. rj1967
    Replies:
    10
    Views:
    800
  4. P3_Takuto
    Replies:
    9
    Views:
    995
  5. xboy23

    Engine Trouble Power loss

    Replies:
    7
    Views:
    1,414