Motorized run fast when starting and the engine stop when I step on the brake

Discussion in 'General Questions' started by SAFECO, Oct 6, 2014.

  1. SAFECO

    SAFECO New Member

    I am having a huge problem, I just got a motorized bicycle and did set it all but one thing is stressing me out is that when I am trying to run my bicycle the engine just go fast and if I step on the brake the engine turn off
    Any idea how to fix that?
    Thank tou
     

  2. KCvale

    KCvale Motorized Bicycle Vendor

    Just pull tab B out of slot C and place it in slot D...

    Welcome to the site and we are willing to help but you really need be way more specific about what exactly this 'Motorized bike you just got' is for any real help.
     
  3. stangkid

    stangkid New Member

    Are you pulling in the clutch, to the point that you can hear it rev when you apply throttle
     
  4. SAFECO

    SAFECO New Member

    Yes I am so pulling the clutch and once I do that while the engine is on, the engine stop working
     
  5. stangkid

    stangkid New Member

    Tighten in the idler screw a few turns and try it again
     
  6. SAFECO

    SAFECO New Member

    It's tight at point that can't be tight more.
     
  7. Purple Haze

    Purple Haze Active Member

    Check all wire connections, sounds like something's shorting out, if so, won't be long till you'll kill the mag, cdi, or both.
     
  8. SAFECO

    SAFECO New Member

    That was so helpful I get it all set and works well, the only problem I still have is the vibration, it's huge and so bad. Any idea how to decrease that?
     
  9. SAFECO

    SAFECO New Member

    when I make a full stop at stop sign and try to turn left or right or go forward, how I can avoid the off of the engine ?
     
  10. KCvale

    KCvale Motorized Bicycle Vendor

    Mount your engine tight.
     
Loading...