Need Help with Electical please!

Discussion in '2-Stroke Engines' started by red77, Mar 1, 2014.

  1. red77

    red77 New Member

    Hello, fist time poster here.
    I have a motor that I am repairing and I am all set to go except I don't have spark. here's the deal..
    I get no spark to the plug(new) but I get consistent (but weak) spark off the plug wire (boot removed). This little guy doesn't have points so I assume its CDI..., something I know nothing about. I have cleaned all the grounding points so that shouldn't be a problem either.. also made sure the pickups from the CDI are not rubbing on the magneto... It ran when I put it away a few years ago.
    If anyone has any suggestions on a fix I would really appreciate the help.
    If not then maybe some suggestion on how to go about finding a replacement..

    Thanks
     

  2. red77

    red77 New Member

    pic

    [​IMG]></a>
     
  3. jaguar

    jaguar Well-Known Member

    cracked CDI
    water probably got into it
     
  4. red77

    red77 New Member

    Where can i find a replacement?
     
  5. battery

    battery Member

  6. jaguar

    jaguar Well-Known Member

    No, his type of CDI requires a trigger input that the Jaguar CDI works without.
    He has to find an original replacement or take his CDI apart and replace any corroded parts.
     
  7. red77

    red77 New Member

    Ya i kinda figured. Any good guides on how to do that? Its obviously cast in some resin so i don't want to just blindly chop into it
     
  8. jaguar

    jaguar Well-Known Member

    if the resin is superficial and there is silicon inside then you are in luck.
    otherwise you're f'd
     
Loading...