need Help with my CDI box!

Discussion in '2-Stroke Engines' started by ben1234567, Sep 11, 2009.

  1. ben1234567

    ben1234567 New Member

    I accidently pulled the wire out of my Magneto/CDI box thing. I tried to stick it back in for about an hour I gotten within millimeters but the wire always seemed to bend once I got close. so finally I just dug some plastic out and found a screw. do i hook my wire to this? I need Somebody that knows a lot about CDIs to give me some info.

    PLEASE HELP!!!!,

  2. biken stins

    biken stins Member

    Take what is left if any out.
    Turn counter clock wise to do so.
    Might think about new wire and cap.
    To put it on screw it on clock wise untill tight.
    That is of course if it is the plug wire.
  3. ben1234567

    ben1234567 New Member


    the thing is I can't screw it back on because the threaded part of the rubber is gone! I havn't dug down too far. do i want to dig past the screw? or just hook my wire to the end of the screw? any more advise would be apreciated.
  4. srdavo

    srdavo Active Member

    There is NO threaded part on the wire. The screw inside, makes the threads.

    Just cut an inch off the wire, and screw the wire into the CDI. Clockwise.

    (Yes... the metal core of the wire makes contact with the screw)
  5. ben1234567

    ben1234567 New Member


    thanks you guys are life savers!
  6. Al.Fisherman

    Al.Fisherman Active Member

    Stock plug wire is trash...use a good quality wire. Look how thin and few strands the wires are in the plug wire. At least that was what my kit had.