new to forum need some advise

Discussion in 'Introduce Yourself' started by 350pwrdyota, Apr 8, 2012.

  1. 350pwrdyota

    350pwrdyota New Member

    i just purchased a panama jack huffy and a 80cc kit from boy go fast,,,got it all installed relativly easy and got it running after doing all the stuff you guys say like replace spark plug boot, ground wire on cdi, got rid of factory conections, put o ring in intake.. ive put some mile on it now and ive found that my rear fender top mount has broken and vibrating real bad..

    what does everybody do with their fenders build new brackets or just remove all together..

    my clutch seems to be slipping when i go to start it,, is this normal or have i messsed something up

    has anybody had any problems with panama jack and engine kits ,,, thanks and would appreciat any reply
     

  2. PatrickW

    PatrickW Staff Member

    Welcome to MBc, 350. Now that you have introduced yourself, be sure to read all you can, including the 'Stickies' at the top of each Forum. They contain a lot of information. For example, Sticky #1 under ‘Introduce Yourself’ has 20 or so links to “How To…” threads, and important pages for you to follow. Sticky # 3 has info on forums, how you are expected to conduct yourself, and where you might find and use various features. But, read all of them, and be sure to use the search feature. If you are still stumped on something, post your question in the proper Forum.

    As far as your fender problem is concerned, I would say that it it is up to you. If you are going to remount it, tho, make sure it is good and solid, or you really will mess something up. As far as you other questions, try the search function and/or start reading all you can on our 2-Stroke Engine Forum...I know that these problems have been addressed in the past. Good luck to you.
    Patrick
     
  3. Cavi Mike

    Cavi Mike Member

Loading...