Carby NT Carb Help-- bad action? wrong cable length? user error?

Discussion in '2-Stroke Engines' started by Snarfu, Apr 14, 2012.

  1. Snarfu

    Snarfu Member

    Hey guys, I need your help....

    Trying to set up my NT Not-So-Happytime carb. Either this thing makes me feel like I'm playing throttle tug o war with a small midget hiding in my float bowl or alternately it feels like there is not enough spring tension and the throttle gets stuck at nearly WOT. So far this is mock up only, not a running bike.

    Any words of wisdom to prevent me from chucking this thing in the river?

    Many thanks.

  2. DeathProof

    DeathProof Member

    not so happy makes me not so happy
  3. Snarfu

    Snarfu Member

    Imagine how I feel.... :shout:
  4. Al.Fisherman

    Al.Fisherman Active Member

    1) the carburetor slide might be in wrong. The cut (on the bottom of the slide) away needs to be lined with the idle screw.
    2) cable length, I've had to shorten 1 out of 6.
    3) cable sleeve might need lubricating.
    4) cable housing needs to have a smooth flow from beginning to end.
    5) might be a kinked cable in the sleeve.
  5. tooljunkie

    tooljunkie Member

    throttle mocked up on bike?i had to drill a small locator hole in the bar-theres a small pin to keep throttle from slipping on bar.i also filed off some marks inside where it was molded,made it smoother. a little lube helped throttle slip on bar.a careful inspection of carb,maybe something is binding?
  6. Snarfu

    Snarfu Member

    This turned out to be the magical solution. Al Fisherman, you rule!
  7. Al.Fisherman

    Al.Fisherman Active Member

    Glad to be of some assistance. Now go ride and be safe.