Odd problem with a 4G

Discussion in 'Transmission / Drivetrain' started by msiert, Apr 25, 2015.

  1. msiert

    msiert Member

    i received a new 4 G and found a snap ring hanging on the output shaft I could not figure out how to get the snap ring in it's proper place? I tried to pull the cam housing out to put the snap ring in but it would not budge so I stopped.


    You can see it in the diagram below, it's #13 snap ring and suppose to fit in the end of the #4 the pulley cam housing. On mine it's hanging loose on the shaft on the outside of the cam housing.



    The first picture is how the snap ring is position on my tranny. See in the picture above how there is a recess between the end of the cam pulley housing and the barring chase inside the housing and on mine in the picture below it is flush. My G4 tranny on the bike you can see the snap ring inside the housing.

    The 3rd picture is just another picture I found on lie of the back side of a 4 G.

    I believe there was a problem during assembly at the factory but is it something that will be a problem?
     

    Attached Files:


  2. bikejock

    bikejock Member

    I would ask customer support from where you got it. If you have trouble contacting customer service from where ever you got it BicycleEngines.com would be happy to help with any technical questions regarding your 4G because they sell these exact same engine kits with the exact same transmissions. I had a few questions about the 4G before I ordered mine and they were a great help and quick to respond. Only took a day or two to get a reply from customer support via email. Also send the picture of the problem so they can help with your issue.
     
  3. msiert

    msiert Member

    Think I fixed it? I gave a good tapped on the output sprocket nut against the anvil and the shaft moved enough to expose the slot for the snap clip so I took off to Harbor Freight and pick up some snap pliers and got the clip installed.

    I believe I have the clip in as far as it will go. I tried to put a mirror on the one on my bike but I can't see all around it? There is more of the clip showing at the opposite end of the eyelets but I believe the clip is wider at that end.
     

    Attached Files:

  4. bikejock

    bikejock Member

    Looks fixed to me. Long as it doesn't drive weird or cause any failure it should be OK. Stop, shut the engine down and take a look at the first sign of trouble. Best advice I can give for now.
     
  5. msiert

    msiert Member

    Think it's good I checked it against the 4G on the bike and used the snap ring pliers to compress the ring a bit and turn it in the chase.

    Plus a close inspection.
     

    Attached Files:

Loading...