Pls help my bike won't fire or start is it my magneto??

Discussion in 'General Questions' started by Huotalicus, Feb 6, 2014.

  1. Huotalicus

    Huotalicus Member

    Pls help me ive had so much trouble Nd now after inspection the coil magneto i notched this burnt bit can someone tell me if its no good or ??
     

    Attached Files:


  2. crassius

    crassius Well-Known Member

    those coils often look pretty bad, but still work OK - the only way to test them is with a cheap multimeter

    search the board here for more info about testing
     
  3. Big Red

    Big Red Active Member

    crassius is right, what can I say about cheap chinese crap. BUT,I've said it before many times, and I'll say it again. 99.999% of the time in a weak or no spark situation, IT'S THE COIL. (about $12 on fleabay.)
    Big Red.
     
  4. ez dave

    ez dave New Member

    ive had these same issues, ivehad the mag go bad and the cdi. ohm the mag , not sure of values, but when you figure it out and if it turns out to be the mag make sure you put silicone around the rubber where the wires exit the case, this is what killed mine.
     
  5. Huotalicus

    Huotalicus Member

    FIXED UR ALL RIGHT UT WAS MY MAGNETO COIL CHANGED IT OUT WITH A NEW ONE AND BAM!!! off i went with the sweet smell of mixed fuel burning once again love it... i figured this out a while ago bug forgot to post it here THANKS TO EVERYONE WHO HELPED ME SO APPRECIATIVE OF THE HELP... 4eva grateful
     
  6. Huotalicus

    Huotalicus Member

    ive now fixed two bikes with bad magneto coil the part in the pic.. FACT ALL WIRES ARE LEADING DOWN INTO DIRECT CONTACT WITH MAGNETO... so fuel leakage and water from rAin or puddles will definitely follow the wires all the way to the coil...

    SOLUTION. shrink wrap or duck tap the exit point from coil where the wires come from engine blue white n black .. if u can safely secure the wires and not allow moisture in.. then u will be safe from these failures .
    id just like to ad that i never did break in my engine and am still able to top 50 flat surface and 55-60 downhill.. and with a 44t sprocket... thinking i blew mg engine. it sat for. months til i finally tried the coil with a new one not swapped out of another. and straight away i noticed the ignition.. theres a big difference in the engine turning over and sputtering then to the actual sound of fuel igniting in ur engine..which makes like a popping sound... ifbh dont know this it can really do ur head in badly.... it dis mine for months... i swapped everything out and still no good... also just cuz u have apark doesnt mean its strong enough to ignite engine successfully... thanks guys
     
  7. Huotalicus

    Huotalicus Member

    FIXED bike wont start/fire weak coil/dead coil

    ive now fixed two bikes with bad magneto coil the part in the pic.. FACT ALL WIRES ARE LEADING DOWN INTO DIRECT CONTACT WITH MAGNETO... so fuel leakage and water from rAin or puddles will definitely follow the wires all the way to the coil...

    SOLUTION. shrink wrap or duck tap the exit point from coil where the wires come from engine blue white n black .. if u can safely secure the wires and not allow moisture in.. then u will be safe from these failures .
    id just like to ad that i never did break in my engine and am still able to top 50 flat surface and 55-60 downhill.. and with a 44t sprocket... thinking i blew mg engine. it sat for. months til i finally tried the coil with a new one not swapped out of another. and straight away i noticed the ignition.. theres a big difference in the engine turning over and sputtering then to the actual sound of fuel igniting in ur engine..which makes like a popping sound... ifbh dont know this it can really do ur head in badly.... it dis mine for months... i swapped everything out and still no good... also just cuz u have apark doesnt mean its strong enough to ignite engine successfully... thanks guys
     
Loading...