Primer Bulb

Discussion in 'General Questions' started by codi79, Mar 27, 2008.

  1. codi79

    codi79 Member

    I have a small Weed Eater motor, around 20cc. When I prime it (or try to) the primer bulb doesnt seen to full up, and it doesnt pop back out. The primer line is free of any debris and is not clogged. I don't know whats going on :confused:

  2. Abeagle

    Abeagle Guest

    The only reasons it will not pop back is because of a clog. think of it like a straw if you plug one end and suck in it, it will collapse until you open one end. Or it could be that the bulb is just bad from old age or contamination.
    Hope it helps, let us know what you find.
  3. hot70cc

    hot70cc Guest

    Disassemble the carb, but lay out the pieces in order so you don't 4get how to put it back together, use a blow gun, clean all that is possible, put back together and if it still don't work, your bulb may be old and not as flexable as when new. I have many weedeater motors, and had the same problem. Just clean clean clean and replace bulb if needed, and also make sure your fuel filter in the tank isn't clogged. Hope this helps
  4. codi79

    codi79 Member

    Okay, thanks. It must be a clog then because when I took the bulb off the carb it was fine, so it must be that one passage right behind the bulb.
  5. codi79

    codi79 Member

    Alrighty, I cleaned out the carb and I got it running. I soon noticed that it was as simple as a hole in the bulb. Not sure how I missed it but I finally know what it is.

    Thanks all who helped
  6. Abeagle

    Abeagle Guest

    Glad to hear you found the issue. :)