problem with broken motor mount

Discussion in '2-Stroke Engines' started by Unregistered, Feb 23, 2008.

  1. Unregistered

    Unregistered Guest

    i got an 80cc(pk-80) kit and assembled it on the Schwinn skyline, the bottom of the Schwinn skyline would not fit the engine so we had to modify it, the modification worked but the screws were too short, the bike worked fine until one day a screw popped out with some metal with it, we dont know where to get a longer screw and we looked everywhere has anyone else encountered such a problem, if so how do i fix it
     

  2. azbill

    azbill Active Member

    Last edited: Feb 23, 2008
  3. gone_fishin

    gone_fishin Guest

    by using a decent subject line, you made your search for help easier...scroll down to see "similar threads"
     
  4. Scottm

    Scottm Guest

    Augi did yo look at the dates of those threads (sorry to go OT)This topic comes up evry 3-4 months like clock work. although there are probably more, just titled incorrectly.
    When you go to lowes or home depot.... look for "all thread" bolt with no head. You can keep some extra on hand and make your own bolts.
    Good luck and I hope it works out for you.
     
  5. gone_fishin

    gone_fishin Guest

    scott: yeah, but this is the guest forum...if someone wants to post the same question instead of searching and gettin' 'er dun, well, so be it...

    so long as a guest post is within content guidlines, i'll approve it...but members don't have to jump in and answer the repeats if they don't wanna.
     
  6. Scottm

    Scottm Guest

    It was just odd quirk I noticed. I like this, it's an opportunity to help out. I hope our guest has a sucessful repair.
     
Loading...