Problems hooking up a Wonderful Creatioms 6V charger

Discussion in 'Electrical' started by blckwlfny1, Dec 10, 2010.

  1. blckwlfny1

    blckwlfny1 Member

    At the risk of seeming presumptuous, I'm going to jump straight into the description. :)
    I am wiring a "Mighty Wonderful" 6v charger.
    As well as the following things (all of which have been RE checked and work fine)
    6v headlight (grounded to frame
    6v tailight (grounded to frame)
    Single-throw toggle switch (has only 1 wire-MUST be grounded to frame)
    6v battery pack

    I took the green wire from the charger and as instructed attached it to the lighting system. The green wire is attached in a 3-way branch to the positive pole of: (1) the switch (2)the headlight (3) the tail light. And all are grounded to the frame (This system worked fine when tested with the battery pack wired in place of the green wire.)
    HOWEVER...when I wired in the charger (green wire) the lights don't work AND the charger's green LED will only light when the charger's black ground wire in NOT grounded to the frame.
    I can't provide a wiring diagram because I have NO IDEA what kind of magical gnomes are in this charger box.
    Does anyone know what's going on?

  2. ibdennyak

    ibdennyak Guest

    Can you draw a diagram??? Almost sounds like you are grounding your whole system through your switch. Sounds like you switch is supposed to be used for a kill switch on an ignition system.
  3. Ypedal

    Ypedal Member

    got a digital camera ? take some pictures of your setup, it helps troubleshoot !

    LED's are unidirectional, unlike regular bulbs that dont care.. so reverse polarity won't work... but when you say " charger " .. you mean like the type you plug into the wall ? or ?????
  4. HseLoMein

    HseLoMein Member

    wire the green and black wires to the + and - terminals of the battery. instructions should have came with it, if not ill scan them and send them to you.