Rough Riding

Discussion in '2-Stroke Engines' started by BikeProblems, Apr 23, 2011.

  1. BikeProblems

    BikeProblems New Member

    Hi there.
    My 66cc motorized bike is riding really rough when i ride it. It feels like it wants to pull and then all of a sudden the engine stops pulling and so on. I was just wondering if anyone knows why this is.
    Also if i hold the throttle wide open it just seems to sputter and die, even if i have wound the throttle on smoothly.

  2. jaguar

    jaguar Well-Known Member

    How many miles does it have on it?
    Are you sure the gas is good? (best to dump it and put fresh gas in)
    Sounds like it could be bad gas, bad electrical connection at the magneto, a CDI going bad, bad crank seals, bad carb jetting, incorrect float level, clogged air filter, etc (the ****ing list can get real long which is why no one else replied)
  3. TucsonDIrect

    TucsonDIrect Member

    It could even even be an overly loose chain! Where it grabs then slacks then grabs
  4. motorpsycho

    motorpsycho Active Member

    If the chain is loose enough to cause a rough ride, it would come off the sprocket.
  5. TucsonDIrect

    TucsonDIrect Member

    Im sorry but you are not correct
    yes its likley
    but that doesnt mean it will fall
  6. motorpsycho

    motorpsycho Active Member

    If the chain is going "slack, loose, slack...." then that means that the rear sprocket is not centered on the hub so it will act like an eccentric.
    this will cause the chain to jump off the sprocket eventually.
  7. BikeProblems

    BikeProblems New Member

    Thanks anyway guys. Got the problem fixed and the bike is running smoothly and fast.

  8. DuctTapedGoat

    DuctTapedGoat Member

    What was the problem and how did you fix it?

    Big thing about these forums is that someone can reference it years from now if they're having problems, and having the solution helps with that.