speedo

Discussion in 'Electrical' started by blue 48, Nov 19, 2011.

  1. blue 48

    blue 48 Member

    hi ive got a cyclops 3 function digital speedo on the bike and it always seems to reset itself while riding. has this happened to others and if so what kind of solutions are there? one thing ive heard is that i could be getting interferance from the kill switch wire so ive relocated the wiring away from the kill switch. havent tested it yet though. any ideas conidered:bowdown:
     

  2. motorpsycho

    motorpsycho Active Member

    it's not the kill switch, it's the frequency coming from the spark plug wire believe it or not.
    one solution is to get a shielded non resistor spark plug wire.
    another solution is to buy a better speedo.
    I had an el-cheap-o e-bay digital soeedo and it would re-set itself when the engine was running, but worked fine with the engine not running.
    I bought a schwinn brand digital speedo from wal mart and have not had one problem with it.
     
  3. blue 48

    blue 48 Member

    ive got an ngk b5hs plug and an 8mm silicone ingition lead (bosch)
    i would like to not have to get a new speedo if possible (unless i go mechanical)
    sooo umm new lead ????
     
  4. motorpsycho

    motorpsycho Active Member

    well, it sounds like you have the bases covered then...it must be something else.
    does it work fine with the engine shut off?
     
  5. blue 48

    blue 48 Member

    it works now after i secured all wires insulated them well and put a dab of silicone under the battery cover. but now im thinking about a mechanical speedo but can only find em in MPH i want KPH. also i realise it used to go into reset mode when raining and i touched it engine on or off
     
Loading...