Weird sound coming from my engine

Discussion in '2-Stroke Engines' started by Rampant, Mar 29, 2010.

  1. Rampant

    Rampant New Member

    Here's whats got me worried.

    Before I describe the problem I just want to tell you about my engine. Now I have already checked and its not the chain.

    F80- 66CC Engine - NOT BROKEN IN NEARLY 200KM ON IT
    1. Engine Type: Single cylinder, air-cooled, 2 stroke
    2. Type of fuel mix :( 15:1/20:1-25:1)
    3. Displacement: 66cc
    4. Ignition: C.D.I. ignition
    5. Max.Power:2.5KW@ 5500rpm
    6. Economy: 100 km/2 litre fuel
    7. Max speed: 45km/h
    8. Fuel tank: 2 litres
    9. Weight: 6.5 kg
    10. Bore: 47mm
    11. Stroke: 38 mm
    12. Compression ratio: 6.4

    Okay, so when I take my hand of the throttle (so no acceleration to slow down) when Im slowing down my engine kind of chugs as it gets slower and makes this weird kind of sound like something is not lubricated right. It almost sounds like an electric bicycle speeding up.

    Note: the engine appears to be performing fine apart from this problem.

    Any suggestions on what might be causing this would be greatly appreciated.
     

  2. motorpsycho

    motorpsycho Active Member

    it could be the clutch. my clutch made a whining sound for awhile, but it went away after the motor got broken in.
    the clutch pads in the majority of these are just rubber pads beleive it or not.
     
  3. Rampant

    Rampant New Member

    Yeah, I have come to the conclusion that it is the clutch. Because when I pull the clutch in the sound goes away.
     
Loading...