49cc 4 stroke redlining at 15mph..

Danaman117

Member
Joined
Sep 8, 2020
Messages
38
I have a new 49cc 4 stroke 5g with dual chain automatic transmission. The gear on the mag rims is a little smaller than the standard bike kit sproket but with my 2 stroke i was going 30 easy with the same gear.. its like I have one speed very powerfull on start actually wants to pop a wheelie. I get to gas it sounds great till i hit like 15mph vibrating really bad like its red lining..sounre sounds like it wants to do another 10mph but somethings holding it back. I have to gas it let off the gas constantly its like i have no play in the middle. Throttle cable is perfect, do i need to break something in somethings deffinately not right..
 


Danaman117

Member
Joined
Sep 8, 2020
Messages
38
I pulled the transmission apart plenty of grease, does seem to get rather hot still.
 

Danaman117

Member
Joined
Sep 8, 2020
Messages
38
Its legal to ride prettiy much anything down the road in this town, did you have any sugestions?
 

Chainlube

Well-Known Member
Joined
Jan 5, 2020
Messages
2,455
My guess would be the clutch isn't grabbing, Darwin might know better. He'll be about in a bit.
 

Danaman117

Member
Joined
Sep 8, 2020
Messages
38
Clutch is grabbing fine i just have to give a lot of acceleration, i read the springs are stiff when new.
 

Vikingimike01

Well-Known Member
Joined
Jul 1, 2018
Messages
1,489
Fuel filter shouldn't cause a lot of problems unless clogged. Gearing? If its redlining at 15 mph you need to change your gearing

could be unbalanced cranks
 
Top