all leads test +, still no spark

Discussion in 'Electrical' started by timmayyy, May 4, 2016.

Tags: Add Tags
  1. timmayyy

    timmayyy Guest

    title says it all, followed the testing guide, everything tested positive, tried 2 different spark plugs, yet no spark... help please?

  2. HeadSmess

    HeadSmess Well-Known Member

    possible that the magneto key is missing. make sure it spins with the engine.

    pop off magneto and sand/clean all contact points.

    black to black and frame, blue to blue, and remove killswitch...

    not much else can go wrong with the things.

    assume its a newer magneto with only the black and blue wires, no white wire?

    sometimes the older white wire magnetos keep running if you earth the white wire...sure sign the magneto is about to die. get rid of and replace if so.

    if everything in the magneto is fine, start thinking of getting a new CDI/coil...little black boxes. horrible things.
  3. 45u

    45u Active Member

    With the stock CDI you have to get the motor turning over fairly fast to get a spark then it is hard to see unless it is dark. Not a real big spark.
  4. 45u

    45u Active Member

  5. jaguar

    jaguar Well-Known Member