Bike idling fast with new plug?

Discussion in '2-Stroke Engines' started by Elmstreetmotorized, Jun 4, 2009.

  1. Elmstreetmotorized

    Elmstreetmotorized New Member

    I have a 66cc china girl. She has been running great but everyone says to use the ngk plugs so i switched the cheap china plug for the ngk. Now she seems to idle fast. Seems that the motor is reving more then before. I tried the screw but even with it all the way out it stays the same. The needle is set to the stock position. Before the plug change I played with the needle settings and found the stock to work best.
    Any ideas why she is running so fast in idle with the new plug?

  2. 2stroketech

    2stroketech New Member

    sounds like you might have a vacume leak. Check the plug to make sure it is tight and sealed.

    If that is not it then take a can of WD-40 and while the engine is running squirt a little around the intake and back side of the carburetor and then around the crank seals. If the engine slows down then that is where the air leak is.
  3. Elmstreetmotorized

    Elmstreetmotorized New Member

    everything should be sealed. Illl have to wait till tomorrow to check. It was sealed and running rather nice before the change. Im 90% sure the plug is seated correctly. Could it be anything else? I didnt know if that ws the way the plug ran?
  4. 2stroketech

    2stroketech New Member

    The plug might give you a little hotter spark= better ignition= better fuel economy= more torque.

    It will not make an engine rev high and not allow you to adjust it. You might have knocked somthing loose or it was all just a happy coincidence.

    The adjustment with no results is a bit of a give away for a vacume leak. I am 99% positive on this.

    The only thing else that I could possible think about is you have the throttle cable out of place and it is holding the throttle open.
  5. BSA

    BSA Guest

    Yea sure does sound like an air leak. Still thats an easy fix :D

  6. EnFlaMEd

    EnFlaMEd Member

    Probably not the problem but just check that the washer in your carb is seated properly underneath the spring. I found on mine after I had adjusted the needle clip one time that somehow the washer flipped upright inside the spring partially jamming the throttle open.
  7. solitus3989

    solitus3989 Member

    I agree with this. Before you go through too much trouble, mess with the throttle cable a bit. loosen it up a notch and if it idles lower, then that's your problem.

    Also, try engaging the bike and giving it no throttle. if it is held open, it will lull you forward at 5-10 miles an hour, even up hills etc.
  8. Elmstreetmotorized

    Elmstreetmotorized New Member

    I'll give all of that a check this afternoon. I know when I started it yesterday I let the clutch out without giving it any gas and the bike moved forward instead of killing it. Maybe it's the cable.
  9. solitus3989

    solitus3989 Member

    Sounds throttle related. Let us know!

    Good Luck!
  10. Elmstreetmotorized

    Elmstreetmotorized New Member

    Well I checked everything i could. Didnt see any issues with the throttle so I thought I would start her up to check for leaks. Only thing is now she wont start at all. With the choke on or off. I pulle the carb off to check for obstructions and found nothing. The few times it tried to start it ran for maybe 5 seconds. When it started it would rev up quickly on its own like i was giving it gas then it would die. Everything is connected and the plug looks good. It is new after all. I'm stumped.
  11. BSA

    BSA Guest

    Hmmm definitely sounds like an air leak. If you can get it running try spraying carb cleaner (or WD40) around the carb clamp, intake gasket, base gasket etc. See if the rpm drops for a few seconds.

  12. 2stroketech

    2stroketech New Member

    If you can not get your engine to run to do the simple air leak test then you will have to do a preasure leak down test. This will intail blocking the intake and exhaust off and putting 15 pounds of vacume to it and see if it holds. If it does not hold for 2 minutes then you need to fill the engine with 18 pounds of air and using a spray bottle with soapy water find the leak.
  13. Elmstreetmotorized

    Elmstreetmotorized New Member

    Well I got her runing this morning. Must have been flooded last night.
    Just to be sure I went over everything last night. I checked the washer on the needle clip. The throttle is freely moving. Went over carb cleaned and reattached with some rtv to make sure it didnt leak. Pulled the head off checked the gasket. Went over the intake gasket and the spark plug. When she started today I tried to ride down the block she would run normal for a sec then got kinda jumpy like it maybe misfired. It didnt bog. then all the sudden it started to rev almost as if I was giving in full throttle. I had to use the choke t kill it because the switch didnt work. took it home got it running and was about 5 feet away when it started to rev up on its own again.
    Could it be a bad cdi or magneto? It is a cheap china kit. It ran fine though till I switched the plug.
  14. Junster

    Junster Member

    When you put the carb slide back in you did check to make sure you lined up the slot with the nub inside right? Then with it together pull up on the cable housing where it goes into the top of the carb. Feel the slide go up and down. Make sure when it's at the bottom that there's at least an 1/8" of slack in the cable before you feel the slide come up. Most of the carbs that come packed with the cable already attached have a kink in the cable right where it goes into the carb. You need to bend the cable straight with your fingers. It's not the ignition or it wouldn't run. If your using the original plug wire did you take the knob thing off the top of the new plug?
  15. BSA

    BSA Guest

    Look it is fairly obvious that you have an air leak. We've already explained how you search for one (using spray can of WD40/ carb cleaner? spray it around the intake gasket, carb clamp etc) Spray it while it's running, when you have sprayed over the air leak the rpm's wil settle down.

    I'd bet you a million dollars it's an air leak. Had so many on my bikes over the last 2 years, there very common. Just a fact of life your gonna get them everynow and then.

  16. Mountainman

    Mountainman Active Member

    it's just amazing !!! I have noticed many times

    it's just amazing !!! I have noticed many times on this site

    one's ask a question

    several good answers come in fast

    the person asking the question -- trys none of them ???

    ride that fine running THING
  17. Elmstreetmotorized

    Elmstreetmotorized New Member

    Sorry for the delay in posting. I havent had a chance to do much with it the last few days because of rain.
    I would like to say that I have 2 bikes. I have, and know how to look for air leaks. I had and fixed one on my other bike before. Also I have checked now on this motor 3 times since this problem arose. None of the times did the bike slow in rpms or rev in rpm when spraying the areas. I checked every possible area where 2 parts connect. all intakes and such. I have removed, cleaned and sealed the intake and carb 3 times now. I have removed the plug, checked the gap and resealed. I replaced with the old plug. I have checked the throttle from top to bottom and the needle and clip as well. I went over all electrical connections and even disconnected the kill switch. So I have taken each suggestion and tried them. I appreciate the help but I am not a 12 year old boy. I am an adult who is mechanically incline and does all my own maint. on all of the vehicles I have ever owned from my 59 studebaker to my new cars.
    I will keep all questions to myself from here on out. Thank you again and goodbye.
  18. eastwoodo4

    eastwoodo4 Member

    does it have a fuel mixture screw on it?maybe its just too lean.i believe that can make it idle up.
  19. Molotov256

    Molotov256 Member

    I'm curious what solution you arrive at, Elm - I just ordered a new plug, and I wanna know what I'm up against before I put it in.