Engine Trouble Bike will NOT run

LMKarting

New Member
Local time
9:11 PM
Joined
Jun 18, 2024
Messages
1
Location
Auckland, NZ
Have had the bike since like September, was running fine through break in and another hour or so, then stopped, (in November) so I replaced cdi and magneto and she fired right back up.

I then started running with no baffle because it was quite a weak engine and needed the power. It ran fine for the next few hours it did. (Has done 10 hours after break in at this point) And then even got better, I've always ran 200 mls if 2t oil to 1 litre of 95 octane petrol. It ran fine.

Around February I was on a ride to a skate park, slowly warmed it up, didn't push it too hard only went a few kms, and then it fully ran away on me, full throttle and kill switch wouldn't work, which I think is what damaged it. I think it got an air leak through the carburetor or bottome of the case. The case would leak straight oil, draining a full tank of gas in a couple months. When the engine ran away, the carb also exploded, the idle screw went flying, the bolts on the intake manifold got stripped and the throttle assembly disassembled. The bike wouldn't run after this.

I ordered a new carburetor (high performance) a new cdi, a magneto, top end kit, and gaskets. I tried the carburetor and cdi first and still nothing. I opened up the engine and the cylinder was perfect condition, wasn't running too rich or lean, everything was fine. I put it back together and used a different cdi, it made a few bangs and then a massive backfire. I had replaced all gaskets. And then I was back to no spark. I've spent around 250 dollars troubleshooting and have had no luck. There is no spark and I'm wondering whether the magnet is cooked or it's something else.

Thanks all!
 
My guess is timing. Killswitch may be faulty. Try removing that first. I dont use one just choke it ro kill it. Possibly magnet misaligned. Possible crank problem as cause. When it ran away it damaged the crank. Misaligned the magnet as a product. Just a guess on your info. More details pls like how it ran b4. At idle,underload,thru full range of throttle. Every detail counts. Any things that stood out to you in the bikes charecter.
 
Also when you sat "backfire" do u mean actual backfire?(thru carb)
I think that was pretty much answered already...lol.

When the engine ran away, the carb also exploded, the idle screw went flying, the bolts on the intake manifold got stripped and the throttle assembly disassembled.
If that had been me, I would have just replaced the entire motor after all that kind of damage he described already figuring there would be damage I did not see...lol...lol.
funny-more-than-a-monkey-with-football-bat-mens-t-shirt.jpg
 
I think that was pretty much answered already...lol.


If that had been me, I would have just replaced the entire motor after all that kind of damage he described already figuring there would be damage I did not see...lol...lol.

View attachment 215664
Lol yeah I see it now lol but... 250$?!?! WTF!?! I could assemble 1 monster build or 2 new bikes from that (I get my frames outa the gutter).
 
Have had the bike since like September, was running fine through break in and another hour or so, then stopped, (in November) so I replaced cdi and magneto and she fired right back up.

I then started running with no baffle because it was quite a weak engine and needed the power. It ran fine for the next few hours it did. (Has done 10 hours after break in at this point) And then even got better, I've always ran 200 mls if 2t oil to 1 litre of 95 octane petrol. It ran fine.

Around February I was on a ride to a skate park, slowly warmed it up, didn't push it too hard only went a few kms, and then it fully ran away on me, full throttle and kill switch wouldn't work, which I think is what damaged it. I think it got an air leak through the carburetor or bottome of the case. The case would leak straight oil, draining a full tank of gas in a couple months. When the engine ran away, the carb also exploded, the idle screw went flying, the bolts on the intake manifold got stripped and the throttle assembly disassembled. The bike wouldn't run after this.

I ordered a new carburetor (high performance) a new cdi, a magneto, top end kit, and gaskets. I tried the carburetor and cdi first and still nothing. I opened up the engine and the cylinder was perfect condition, wasn't running too rich or lean, everything was fine. I put it back together and used a different cdi, it made a few bangs and then a massive backfire. I had replaced all gaskets. And then I was back to no spark. I've spent around 250 dollars troubleshooting and have had no luck. There is no spark and I'm wondering whether the magnet is cooked or it's something else.

Thanks al
 
Either way don't give up! These ppl on this forum can guide you thru ANYTHING. Yes a new motor is a much more reasonable idea but If your already 250 in the magnet is pennies. Go to auto zone and get a spark tester if need be they're cheap. Are you sure there isn't spark?It could never have backfired if not.it clearly timing. Either in the ignition system(can be fixed) or mechanical damage(not worth fixing) but don't leave us on the edge of our seats! Update when u can. Lol
 
Go to auto zone and get a spark tester if need be they're cheap.
They do not have Autozone stores in Auckland, New Zealand...lol...lol.

Ya gotta keep in mind that this is a forum that is world wide...lol.

LMKarting

New Member​

Local time 3:05 PM
Joined Jun 18, 2024
Messages 1
Location Auckland, NZ

250.00 New Zealand Dollars equals
152.98 United States Dollars
 

Engine Trouble Bike will NOT run​

After all that damage, I am not surprised, I would have just given it a decent funeral and burial myself and buy a new engine...lol.


This f***in guy.... is right on the money lol. I hate calling it quits. Just straight won't. I've been a s**tbox wizard my whole life but I solidly take this guy advice on these bikes. Even a seasoned mechanic can botch these. They're cheaply made and as result VERY unforgiving. One careless mistake BOOM gone. As you have learned. However we've all blown them up. It's part of the process with learning these. Hell sometime you get a dud. Most companies will fully compensate you for a lemon if you approach it correctly tho.
They do not have Autozone stores in Auckland, New Zealand...lol...lol.

LMKarting

New Member​

Local time 3:05 PM
Joined Jun 18, 2024
Messages 1
Location Auckland, NZ
 
Back
Top