Engine Trouble Bike won't run...

Matt Barrack

Member
Joined
May 30, 2017
Messages
99
So I started up the bike. Gave it speed, let go of the clutch, hit the throttle. Then the throttle became very limp. Then it wouldn't run when I started it and then it died. And on top of that now the throttle is limp and won't do anything. Anybody know what to do?
 


Matt Barrack

Member
Joined
May 30, 2017
Messages
99
I just started it for the first time and now the throttle is all limp. I opened up the carb to see if anything was the matter and it seemed fine. But where it enters the Carb (the end of the rubber outside) pops out from the carb. And if it doesn't it does the same on the other side. (where it enters the throttle housing). Anybody know what is going on?
 

crassius

Well-Known Member
Joined
Jul 23, 2012
Messages
4,572
doesn't sound like the carb in your avatar (no rubber there) - do you have a pic?
 

Navrothian

Member
Joined
May 22, 2017
Messages
50
Sounds like the same issue I dealt with a few weeks ago. In my case, the little end that is on the throttle cable broke off, it happened to me several times.

Unscrew the throttle from the carb and have a look.
 

Matt Barrack

Member
Joined
May 30, 2017
Messages
99
it keeps popping out. Not from the carb but from the throttle housing. Would a brake lever work as a substitute for the twist throttle?
 

crassius

Well-Known Member
Joined
Jul 23, 2012
Messages
4,572
looks like a POS speed carb - they are sometimes smaller that usual carbs, but the adjusters should take up the slack
 
Thread Status: Hello , this thread is over 3 years old. You can still reply if relevant, but sometimes it's better to create a new thread to get more replies!
Top