blown engine seal

E

eggohead

Guest
Hi, my Spooky Tooth Violation stopped running recently. I've been told that it most likely has to do with one of my main engine seals being blown. To check on that, I was advised to check under 'the right and left side covers' for any oil that had leaked.
I'm not very mechanically knowledgeable, so I don't know what was meant by the 'side covers'. could somebody explain to me where they are?

Thanks, Josh
 


F

fetor56

Guest
Josh...No biggie man but this post relates directly to frame mounted bikes and should really be in the correct section(Frame-Mounted Engines & Drive-Trains)
Anyway "side covers" refer to the actual aluminium covers on each side of the engine...2 smaller ones on the left,1 larger one on the right.
This may help with your problem because it's been posted before so remember to READ as much as possible FIRST.
http://www.motoredbikes.com/showthread.php?t=8074

PS....i have my doubts that this will fix your problem...your engine is pretty new and an oil leak here is unusual even for an older engine.
Try it,but if u have no success get back to your thread with the COMPLETE symptoms....u just said it stopped running but u didn't say more.
 
Last edited by a moderator:
E

eggohead

Guest
thanks fetor. i'll post in that section next time around. i didn't quite understand the back and forth in the old thread you sent me. i really don't know a whole lot--but your explanation helps out. and i'll make sure to read old posts first. hopefully i'll be able to understand them. Josh
 
Top