• Register now! It's free and easy.
  • Show your bike to the world, upload a photo today!
  • Hi Guest, did you know we have a dark style? It might be easier on the eyes at night time! Try it out here: Style Chooser

Carb problems...

delorean_mac

New Member
Joined
Apr 21, 2008
Messages
17
I have a 31cc happy time engine that leaks out of the air intake on the carb. I have taken the carb apart many times... but I can't seem to find what could be causing it. Any ideas? Also, I have started the engine while it has been leaking, but I haven't been able to start it the past 2 days.:( I pulled it several hundred times, and finally it started to start. It will run for a couple of seconds after 50-60 pulls, but by then I can't pull the string any more. Can anyone help me?
 


sparky

Active Member
Joined
Mar 19, 2008
Messages
1,429
I can't really suggest anything to ya right now...

but I'd like to know where you got a 31cc happy time from?
 

delorean_mac

New Member
Joined
Apr 21, 2008
Messages
17
Craigslist!

I got my 31cc happy time from a ryobi weedwacker from craigslist for $20.
 

sparky

Active Member
Joined
Mar 19, 2008
Messages
1,429
I'm pretty sure Ryobi weedwhacker isn't considered a "Happy Time" engine. They're typically sold in kits, and are designed to be frame mounted... and they have a manual clutch.

Anyway... the carb is prolly the most complex part of an engine. I'm not a bit surprised that you're having problems with yours, as I'm having problems with mine as well. Mine's not that serious enough for me to research more -- yet.

You've prolly already seen the Crash Course, but in case you haven't... scroll down to Advanced Repair and check out all the carb links. Most problems seem to be solved when O-ringing the carb and/or using Permatex 1A gasket sealer on both sides of their gaskets.

G'Luck!
 

delorean_mac

New Member
Joined
Apr 21, 2008
Messages
17
Sorry. I saw the crash course already, but I guess I just misread... I was looking on google and I found the manual for my weedwacker, and I read that taking off the carb cover and air filter while starting the engine voids the warranty. Well, the carb cover has been off ever since I got it since the carb's been leaking the whole time. I was desperate, so I slapped on the air filter and cover, and on the first couple of pulls it started. Wow. I'm an idiot. It only ran for a couple of seconds when it died. I just need to adjust an idle screw. Then I pulled it again to start it, and the pull starter was moving freely. (this is hard to explain) When I pulled it, it wasn't moving the piston. I tried to take off the plastic casing to look inside, and whaddaknow, I have to take the clutch off. I got the cover plate off, but now I can't seem to get the rest of it off. Any sUggestions? (sorry this is so long:) )
 
Top