Engine Trouble Carburetor not letting fuel into engine!

Discussion in '2-Stroke Engines' started by v2sonic, Mar 22, 2014.

  1. v2sonic

    v2sonic New Member

    This bike has worked before but this time, it didn't work and instead started up and could rev without accelerating whilst slowly decreasing power until the engine dies out. The bike also can't idle and has to be kick started. I decided to open the carburetor up and see if there was a problem within it. I found that the carburetor wasn't letting fuel into the engine even when i twisted the throttle and i saw the slide needle part go up. I also saw that the fuel was being stopped at the lever to let fuel in. It was reaching the rear of the carburetor and leaking fuel but not reaching the place where it is supposed to flow into the engine.

    Please help!!

  2. nicolo426

    nicolo426 New Member


    Hello V2sonic,Have you tried troubleshooting it?
  3. nahay

    nahay New Member


    Have you tried troubleshooting the carbehhh? Usually it fixes the error and will usually scan for any other issues. Hope this helps
  4. birdmannn101

    birdmannn101 Member

    Fuel cap not vented? Remove it to see if it runs better.
  5. HeadSmess

    HeadSmess Well-Known Member

    that first post just makes me believe that the OP has no understanding of a carburettors operation.

    when the motor is NOT RUNNING, the carb will NOT LET FUEL INTO THE ENGINE.

    they require airflow to suck fuel up from the bowl via the needle and jet. this only happens when they are being turned over at a certain speed!

    that lever thingy is the fuel valve, its SUPPOSED to stop the fuel at a predetermined level, and there should be NO FUEL DRIPPING FROM THE END OF THE CARB.

    go back to square one, read up on how a carb works.

    to me. the fuel height is too high, its flooding.