Frame mount Huasheng 4 stroke, no acceleration

Discussion in '4-Stroke Engines' started by NeoEleganceDesign, Aug 11, 2008.

  1. NeoEleganceDesign

    NeoEleganceDesign New Member

    Hey guys,

    A few months ago I picked up a frame mount 4 stroke kit from and have been piddling around putting it together. I finally got it all together about a week ago. At first I had a few issues with the chain popping off, but I think I set the chain tension correctly today. I can get it to start and idle just fine. However, when I engage the clutch and give it gas, nothing happens.

    The motor revs up and I can see the clutch lever engage, but there isn't any power going to the rear wheel (even at full throttle with the choke off). I know these motors aren't extremely powerful, but I'm pretty sure I should feel at least some forward motion while sitting on the bike while it's stopped. I only weigh 140 lbs, so I highly doubt my weight is an issue. The same thing happens standing next to the bike with the clutch engaged and full throttle. I opened up the gearbox (Grubee Skyhawk II, I think) and everything looks okay.

    What could be the problem?
    Last edited: Aug 11, 2008

  2. ocscully

    ocscully Member

    Any chance you left out the key that engages the clutch to the output shaft of the motor?


    Attached Files:

    • 44.jpg
      File size:
      11.1 KB
  3. NeoEleganceDesign

    NeoEleganceDesign New Member

    The key from the output shaft of the motor is there. I took the cover off the gearbox, removed the two secondary gears and started the motor and the gear that is connected to the output shaft of the motor spun just as fast as the motor and the key and keyway for the output shaft of the gearbox seems fine.

    I included a couple of photos this time.
    - The first is the gearbox with the cover removed.
    - The second is the gearbox output shaft with the clutch disengaged.
    - The third is the gearbox output shaft with the clutch engaged.
    - The last two are pictures of the bike itself from both sides.

    Attached Files:

  4. ocscully

    ocscully Member

    Since the key is installed, then it pretty much has to be the engager mechanism. Is there any slack in the cable and housing that operates the engager? Maybe you aren't getting full engagement when the lever is pulled in? Remove the chain from the output sprocket of the gearbox and then operate the engager by hand with the motor running to see if the output sprocket turns. If you could take a photo of the cable attachment to the engager perhaps more could be determined?

  5. NeoEleganceDesign

    NeoEleganceDesign New Member

    Well, I removed the chain and the output sprocket spun when I engaged the motor. I figured that maybe I tightened the chain too much so I added a couple of links back and loosened the tension wheel and still no power to the rear tire. Here' the photos of the engager with the lever pulled in and released. With the current tension at the grip, the lever only needs to be pulled in half way to pull the engager all the way.

    Attached Files:

  6. ocscully

    ocscully Member

    I'm stumped at this point, but I do notice that the configuration of your intermediate gear is different than shown at both the GRUBEE and web site. See photo below and compare with the one you have. Why does the smaller gear go all the way thru the larger one? It very well may not be the problem and is just a design change the came after the photos from the factory were taken. But if both gears aren't keyed to the intermediate shaft it could be the problem? The other thing I notice is that I don't see that you have cable housing all the way to the barrel adjuster for the engager? It could just be the angle of the photo though.

    Hopefully Houghmade and some of the other members with these kits will have some ideas?


    Attached Files:

    Last edited: Aug 11, 2008
  7. HoughMade

    HoughMade Guest

    Based on what you said about the keys being good and in place and the picture above, it looks to me like the engager lever is not engaging all the way when you pull the handle (an assanine design, by the way). With the engine off and the rear wheel in the air so it can spin, push the engager lever as far as it will go towards the way it engages, the spin the rear wheel forward- you should be able to feel a distinct difference between engaged and not engaged. With your hand on the engager lever, you will probably feel it engaging. When mine is engaged (which is all the time), the lever looks to be further back than yours. Here is a picture- you will note I reversed the engager so it is engaged all the time except when I pull the handle.

    Irish John has this setup too and knows more about this gearbox than just about anyone; maybe he will chime in with his thoughts.

    Attached Files:

  8. jimraysr

    jimraysr Member

    Centrifical Clutch on Backwards ?

    I am thinking that you may have put the clutch on the motor backwards (with the side that you can see the springs from facing out)

    I am also guessing the clutch segments will be thrown out, but not really wedge against the bell housing. Thus no real power to the output.

    Worth a check?

  9. cruiser66

    cruiser66 Guest

    This GB has a lot of keys. Did you check the key for the engager and the key for the 11T sprocket? One way to isolate the problem would be to remove the cover to expose the gears and remove the chain so that you can spin the GB sprocket by hand while observing the gears. Try holding the main gear stationary with one hand while spinning the sprocket with the other hand. If you are able to spin the sprocket without the main gear spinning, then it sounds like a key is missing or broken for either the engager or the sprocket. Make sure that the engager is set to transmit power from the GB to the sprocket before doing this check.

  10. grummy

    grummy Member

    Nice lookin ride Neo ..specially that tank of yours I wonder where can I get one ....
  11. jimraysr

    jimraysr Member

    Neat Gas Tank

    I just noticed your gas tank. Looks like a good replacement for my China one. I think it would be a good idea for me to get rid of the one on the top tube and save my 30" inseam from damage when something unexpected happens. )

    If you could tell me the brand, price and where I might get one, I would appreciate it.

  12. grummy

    grummy Member

    An your saddle too ^^ it looks soo comfy
  13. Irish John

    Irish John Guest

    Sounds like it must either be the engager isn't pulled in hard enough against the final spocket drive as frquently happens first time after a build, or the key is missing in the final drive sprocket shaft. If it's the latter I wonder how that could be cos they come already assembles don't they.

    HOMEYYYGG New Member


    You can get tank from . Please let me know how you make out cause im basically having the same problem, have seen a few postings they refer to the idle & fuel mixture needing adjustment. I got mine to work, but once i put a load on it , it doesnt seem to engage. So anything you can come up with would be most greatly appreciated.:grin:
  15. NeoEleganceDesign

    NeoEleganceDesign New Member

    Thanks for the suggestions guys. I would have responded to them all sooner, but for some reason motoredbikes wasn't informing me of posts to the topic (gotta check my settings).

    I tried squeezing the handle pretty hard to make sure it was engaged all the way, but I'll try putting my hand on the lever itself tomorrow.

    Reversing the direction of the lever makes sense. A bit more like a motorcycle that way. Once I get the thing up and running, I might try that.

    The motor and gearbox were already assembled when I got the kit. The first time I started the bike after putting it together caused it jump forward when the engager was squeezed, but it hasn't shown any power to the rear wheel since then.

    Are there two keys on the output shaft of the gearbox? I only checked the one on the inside of the gearbox. If there are two on that shaft, it could have sheared off on the sprocket side. I'll try turning the GB sprocket by hand tomorrow to see if that's the problem.

    grummy and Jim, the tank is a NOS steel tank that was originally made as a replacement for the Four Cycle Lauson Engines quite a few years back (I think it holds a 1/2 gallon). I got it off eBay from a guy that was selling old lawnmower parts and it was the only one he had. Briggs and Stratton made a similar round tank as well. The B&S ones come up on eBay more often than the Lauson ones (in fact, the one I got was the only one I saw for about 3 weeks). If you're looking for a 1 gallon tank and willing to pay about $110 +shipping, there's a guy that sells aluminum tanks (6" dia. x 9" long) for dune buggies and choppers (I think his ID is "coyote-gear").

    It's not nearly as comfy as it looks. Once I get the bike running, I'm thinking about saving up my nickels to buy a Brooks saddle in a similar style.

    I'm going to try HoughMade's test tomorrow to see if I'm just not getting the engager in far enough.

    Unless they just started selling them, bicycle-engines only sells the peanut gas tanks.

    If the other ideas don't work, I might try to adjust the idle/fuel mixture to see if that's at least part of the problem I'm having, but with full throttle and engager squeezed, I'd assume I would still have something (even if the mixture is off).

    I'll try to let everybody know what I find out tomorrow after testing the ideas you all gave.

    A couple things I forgot to mention before.
    1. If I lift the back tire up and give it a little nudge with my foot while the engager is squeezed, it will spin with the motor (just really slow).
    2. Also, with the chain removed, the output sprocket on the gearbox spins when the engager is squeezed.

    If there is a separate key and keyway on both the final gear side and the sprocket side of the output shaft, I'd guess that the sprocket side one is sheared off (or at least damaged). I still need to contact Jeremy at to see if he knows what's wrong since he sold the kit to me.
  16. HoughMade

    HoughMade Guest

    Irish John just replaced the key on the output gear which had sheared. Sounds more and more like you could have a similar issue.
  17. Irish John

    Irish John Guest

    Yes that key is on the outside of the gearbox between the sprocket and the shaft and is small and, I suspect, a bad batch of key steel made from fudge or cheese. Other people in Oz have been having sprocket keys shearing. I fixed mine but the sprocket failed tonight. It came loose in it's own assemblage and probably the grease leaked out and the tiniest bearings I've ever seen failed. It's a watchmakers job to fix so I'm getting a new one. I'll have to make another key now. The sprocket itself is held together by a reverse threaded flange that has two small holes in it for a special tool but a punch will work and a big flat screwdriver to stop the middle bit turning. Incidentally you'll probably need gear pullers to remove the sprocket if it was assembled with a chinese sledge hammer.
  18. NeoEleganceDesign

    NeoEleganceDesign New Member

    Son of a Chinese noodle! Is the key made with navel lint and baby tears? It turns out the key sheared right off on the sprocket side. You can see what's left of it in the photos below. If I didn't know it was supposed to be one piece (instead of two), I'd think they were never attached. It's just my luck that it would shear off before I even had a chance to ACTUALLY ride the thing. Though I guess it's better to have it happen at my shop instead of on the road.

    So I guess the next question is, where can I find another one? Ideally one made with American steel instead of rice pudding. Have you found a good source for these Irish John?

    Attached Files:

  19. HoughMade

    HoughMade Guest

    They sell keystock at Ace Hardware, or most other well stocked hardware stores. Also, a small engine shop should be able to help you out.

    Cream cheese, by the way- cream cheese.
  20. NeoEleganceDesign

    NeoEleganceDesign New Member

    So can I just smack the keyshaft out with a rubber mallet or is there a special way of removing it? I'm getting less impressed with the assembly of these things the more I work on the bike.

    Oh... creamcheese. I knew it couldn't actually be any kind of metal that does anything. So it's just painted to look like steel.