HS 142 Pull start issues

Discussion in '4-Stroke Engines' started by Pete Lawrence, Feb 15, 2013.

  1. Pete Lawrence

    Pete Lawrence New Member

    I was riding the other day, and when i went to start up the engine again (i have the idle set a bit too low) the chord had no feeling of weight behind it? It feels as if im just pulling the spring back, and from what i can tell, its not connected to the engine anymore.

    Thinking this should be an easy fix, i tried to unscrew the three bolts holding the cover on, only to find that unscrewing them seems to do nothing, they just spin and never change...

    Whats going on?

    Edit: I have the cover off, and from what i can tell, it seems to be the plastic connection part off the pull start isn't connecting to the flywheels adapter thing...
    Any ideas?
    Last edited: Feb 15, 2013

  2. EZMJon

    EZMJon Member

    Post some pics. You may need a new pull start.
  3. Pete Lawrence

    Pete Lawrence New Member

    Problem solved, i got the cover off, and found that the two alan key shaped rods inside the pull start had slid down their little track thing.. for future reference: All you need to do to fix it is to slide them clockwise up the little slope into a more vertical position.
  4. abikerider

    abikerider Member

    I had similar problems. I used a little grease on the plastic ramp those rods slide on to keep them from sticking.