Clutch HT Clutch help

brendonv

Member
Local time
8:46 AM
Joined
May 18, 2008
Messages
286
Location
Perth, Australia
Hey guys ive just installed my new zbox HT engine but i cant get the clutch cable in. Its like the cable isnt long enough, i cant pull the clutch in to engage it as its very stiff, should it be this stiff? I can push it in but it is very hard to do, shouldnt it go easy? Also the cable doesnt fit through the gap in the clutch lever, the gap is slightly to small and the cable wont slide in. Other than that its all working fine lol. Thanks guys, ill have pics up of the build tomorrow as i still have to do the clutch, fit muffler and sprocket and chain. XD cya!
 

brendonv

Member
Local time
8:46 AM
Joined
May 18, 2008
Messages
286
Location
Perth, Australia
i got it from zbox but the instructions are pretty bad. The cable is way to long so i think ill cut a bit of the housing off so i get more inner cable. That will work. All these dumb mistakes ive made today ive just thought about tonight so i have to change many things tomorrow haha. Should get it all on by tomorrow night. Get some high grade motorcycle oil and im laughing.
 

BoltsMissing

Active Member
Local time
1:16 AM
Joined
Jan 31, 2008
Messages
895
Location
South Australia
Ok, there is a instruction link on zbox web site. step 7

If the cable seems stiff, take the lot off the bike and hang it up, add some oil in the through the outer cable with the inner cable in, and allow it to drip through over night.
The cable does stretch and ya gonna have to do a few initial adjustments at the clutch arm after the first few initial rides.
OR, replace the inner cable after a while with a HD stainless steel inner brake cable, it'll stretch once or twice initially, then it's almost bullet proof.
 
Last edited:

brendonv

Member
Local time
8:46 AM
Joined
May 18, 2008
Messages
286
Location
Perth, Australia
but the cable is way to long for my bike anyway like im talking 30cm so ill cut the housing and put a new cap on the end so i got lots of cable. Ive got it all planned, ill take the clutch cover off and grease that as well.
 

BoltsMissing

Active Member
Local time
1:16 AM
Joined
Jan 31, 2008
Messages
895
Location
South Australia
Hey guys ive just installed my new zbox HT engine but i cant get the clutch cable in. Its like the cable isnt long enough, i cant pull the clutch in to engage it as its very stiff,

?????

ok, guess you got it figured then,
 
Top