Huasheng 4 stroke shakes and wont take off

shereegami

New Member
Joined
Jun 8, 2019
Messages
19
4 stroke Huasheng motor on my bike shakes pretty bad when I give it any gas at all has anyone else had this problem? how do I fix it?
 


shereegami

New Member
Joined
Jun 8, 2019
Messages
19
I'm not sure I just bought it last week and haven't even really got to ride it if I lift the back tire and give it gas it's fine spins like a champ ...soon as I get on and give it gas it's like the chains going nuts and the motors jumping or shaking or sounds like a grinding noise like the chains skipping on the sprocket or somthing
 

shereegami

New Member
Joined
Jun 8, 2019
Messages
19
but at odle speed it's fine and without the chain on I can rev it up all the way and no problemss....I took off the clutch cover gave it gas and the cluch is opening up all the way so I cant figure it out
 

CrazyDan

Well-Known Member
Joined
Jul 9, 2016
Messages
2,165
You have a broken key on your output sprocket in your transmission most likely, or the one on the clutch shaft if it a straight shaft engine. I had those exact symptoms. Take off the bolt holding it on and give it a check. I bet this is the problem, good thing it's an easy fix. Sounds like you purchased the bike from someone that had that issue and didn't think the internet might help. Welcome to the forums.
 

shereegami

New Member
Joined
Jun 8, 2019
Messages
19
I got it off amazon... is there a link or somthing that might show me how exactly to do it..and thanks man.
 

CrazyDan

Well-Known Member
Joined
Jul 9, 2016
Messages
2,165
Oh you built it yourself? Did your drivetrain seize while moving at any time? That's usually what causes keys to shear.
Here is a video that describes keys, its a little painful to watch, but gets into the nitty gritty.
 

shereegami

New Member
Joined
Jun 8, 2019
Messages
19
if u mean did I mount it and put the back sprocket on the bike and the throttle n cables yea I did....but I'm not sure what u mean by seize
 

CrazyDan

Well-Known Member
Joined
Jul 9, 2016
Messages
2,165
Like did the chain drop and cause the rear wheel to lock? It sounds like you have a broken or missing key on one of the shafts. Which transmission do you have? Can you link me to the kit?
 
Top