Engine Trouble **!! MY BIKE WONT START !!**

JONNI

Member
Joined
Mar 3, 2017
Messages
30
I have been given a motorised bike to fix and got it running perfectly, then I come back 4 days later of not riding it and the bike was really hard to start and then stopped working. So I tested the spark on the top of the cylinder head and had no luck. I brought a new magneto, a new cdi and a new spark plug, but it still won't spark. When I ride the bike I hold the clutch in, petal, let go of the clutch, I know that the pistons are moving and that the bike has compression. Inside the magneto case there is rust on the magnet that spins and I'm not sure if it is effecting the ignition. Could someone please help me!!!
 


JONNI

Member
Joined
Mar 3, 2017
Messages
30
how about the plug wire/ HOW ABOUT THE KILL SWITCH? OFF OR ON? TRACE IT BACK WITH A METER...
 

gary55

Well-Known Member
Joined
Nov 27, 2012
Messages
3,963
Dudes the last time the OP was on here was dec. 2. Giving it's been three months don't you think he probably has it fixed by now.
 

Frankenstein

In memory of Frankenstein 1991 - 2018
Joined
Jun 24, 2016
Messages
5,077
Dudes the last time the OP was on here was dec. 2. Giving it's been three months don't you think he probably has it fixed by now.
His username is in caps mode.. This type of behavior should have been expected.
 

MotorBicycleRacing

Well-Known Member
Joined
Jul 3, 2008
Messages
2,344
Woah! the coil is shorted out wired like that.the tab that has all the black wires on it should only have one wire usually white and not used the black wire with eyelet on mounting bolt or the soldered one should run straight to the black wire of cdi! So you can disconnect all the black ones from tab on coil run one of the grounds to cdi and hopefully the coil is still good.
Woah! there was nothing wrong with his coil as wired before he messed with it.
Just because you have never seen one doesn't make it a mistake or wrong.

All my coils have been coming like that for a long time. It is an improvement.

There is no white wire.
Blue goes to CDI
Black goes to CDI and also goes to the body of the coil.
 

gary55

Well-Known Member
Joined
Nov 27, 2012
Messages
3,963
Woah! there was nothing wrong with his coil as wired before he messed with it.
Just because you have never seen one doesn't make it a mistake or wrong.

All my coils have been coming like that for a long time. It is an improvement.

There is no white wire.
Blue goes to CDI
Black goes to CDI and also goes to the body of the coil.
Woah? This point was also established Dec. 2 post #25 with a apology. You know like 3 months ago.
 

JONNI

Member
Joined
Mar 3, 2017
Messages
30
i love to put bikes back from vintage, broken to on the road and screaming! I just got the same bike out of nevada. 2010 for 150.00 seized engine.. I dropped the motor put in a monster scooter 50 cc manuel clutch motor , wired it up in 3 hours flat! RUNS LIKE A CHAMP! except i now need to do the wheel bearing change , brakes burnt like a crisp! Hee haw. 5 wire stator .GREEN IS GROUND< BLACK IS COIL , WHITE ACCESSORIES< YELLOW LIGHTS< RED IS ignition.. THE OTHER 5 smaller wires,purple , pink, green stripper is gear shift indicator light.yellow and blue. these are cdi, speedo, blinker, battery charger. the diagram is at HOOPERS IMPORTS fyi
 
Top