My Dax 70 engine wont start, Need help?

Local time
10:29 PM
Joined
Jul 3, 2008
Messages
362
Location
Philadelphia, PA
First off, I have a disc brake hub, so in the mean time while I wait for my disc mount sprocket, I made a prototype sprocket for the rear just to start to engine, I used the same sprocket that came with the engine, and just brought longer bolts, I mounted everything one and used the idler as a guider to avoid chainline problems (which it had). I had a few seconds of riding till the chain jammed up on me. In those seconds I had the engine didnt really start up? Personally I thought it may be a potential problem. In addition, I noticed my Carb will leak fuel as well. Whats up with that?

You guys have any suggestions? or Should I wait until my disc mount sprocket gets here, then test things out?
 
Local time
10:29 PM
Joined
Mar 16, 2008
Messages
685
Location
Treasure Coast, Florida
Alot of the front sprockets that come with the kits dont quite fit the chain initially, the chain will wear quickly and work fine. I would suggest, as it did in the instructions with my kit, that you file or grind the teeth on the edges so that the chain does not bind up..
 

Skyliner70cc

Active Member
Local time
8:29 PM
Joined
Nov 17, 2007
Messages
1,338
First starts take a while for a bunch of reasons. They include time for float bowl to fill, rings not seated (low compression), choke at that just right setting.

First starts usually take me 2-3x normal distance to start but I usually do my 1st starts downhill so its not that hard.
 
Top