Engine Trouble Need help pls - Bike Wont Start

Definitely look for air leaks if there is none there is something wrong with your carb even if your carb was really lean it should still start and run for a few seconds. Float could be set wrong and not letting fuel into the carburetor
 
Why is c-clip broken? How do you know?
The C clip can just pop out, or the little tab used for instillation and removal can break off
The tab can break off because the piston pin broke it
Take the head off and look at the cylinder. If the cylinder wall is all gouged up that means either the cilp broke or it came off
got stuck between the cyl wall and piston and ruined the cylinder and piston

For these reasons many will upgrade the piston pin clips to a higher quality
 
You are all shooting in the dark without at least some decent pictures to start off with to at least look for something obvious as being a possible problem rather than making random wild blind guesses.

I'm just waiting for pics before getting involved in guessing games on a brand new engine that the OP says has never even been able to start to begin with...It has never been run.

I've been struggling hard with my brand new motorized bike for about 5 months now, and I can't figure out why it won't start.
 
You are all shooting in the dark without at least some decent pictures to start off with to at least look for something obvious as being a possible problem rather than making random wild blind guesses.

I'm just waiting for pics before getting involved in guessing games on a brand new engine that the OP says has never even been able to start to begin with...It has never been run.

Yeah the broken C clip is probably not the issue, I just answered a question of Why and How post #23

Post #2 I suggested he throw away the China S/P and get a NGK S/P it might be that simple
 
You are all shooting in the dark without at least some decent pictures to start off with to at least look for something obvious as being a possible problem rather than making random wild blind guesses.

I'm just waiting for pics before getting involved in guessing games on a brand new engine that the OP says has never even been able to start to begin with...It has never been run.
Look, nobody's here to play games just with you or throw around some wild guesses, but this still was what the spark plug looked like!
My bad if that camera isn’t as good as yours, probably not living up to your expectations.
Just waiting on those pics before you’d start guessing on this brand new motor. That’s right, it’s never been run because it’s an unknown issue.
 
Definitely look for air leaks if there is none there is something wrong with your carb even if your carb was really lean it should still start and run for a few seconds. Float could be set wrong and not letting fuel into the carburetor
Okay, I'm not sure where and how to check for any air leaks, but there don't seem to be very obvious ones to me.
 
The C clip can just pop out, or the little tab used for instillation and removal can break off
The tab can break off because the piston pin broke it
Take the head off and look at the cylinder. If the cylinder wall is all gouged up that means either the cilp broke or it came off
got stuck between the cyl wall and piston and ruined the cylinder and piston

For these reasons many will upgrade the piston pin clips to a higher quality
Well, the manual didn't instruct me to remove the head and look for a missing C-clip. It only suggests mounting the kit on a bike, and then, after only '2 hours' of some average work, you should be able to start it. Unfortunately,
I don't have these tools yet and don't know where to get them to unscrew those cap nuts. The manufacturer also doesn't mention searching for such a popped out C-clip, so that’s not an issue anymore.
 
Back
Top