Discussion in '2-Stroke Engines' started by shaddy, Dec 3, 2013.

  1. shaddy

    shaddy New Member

    i just finished installing 80 cc motorized bicycle kit ,
    the engine wont start
    i checked the following :
    1- the magneto , cdi and spark plug , the reading locks fine
    2- the cluth setting
    3-unlocked the kill switch

    there is a spark but the engine wont start, i expect the problem is the carb ,

    any idea or similer problem ??
    Last edited: Dec 3, 2013

  2. crassius

    crassius Well-Known Member

    try the choke and the tickler button - if nothing that way, try squirting fuel into carb - if it is a single speed bike, pedal real fast
  3. jaguar

    jaguar Well-Known Member

    If that dont work then flip the magneto around. When it is reverse of how it should be then the spark happens at the wrong time.
  4. shaddy

    shaddy New Member

    there a fuel already on the carb , i checked by unscrew the drain screw , i tried the choke at the 2 position and also the ticker
    its a multi speed bike , i padal more than 20 min , and nothing
  5. shaddy

    shaddy New Member

    ok but how to flip the magneto ?
  6. crassius

    crassius Well-Known Member

    it may be a timing problem, but if you don't have someone in your area to borrow a diff CDI unit from to test, it may be hard to tell - have you tried taking off the air filter and have someone spray starting fluid into the carb while you pedal it?

    also, a spark plug will sometimes spark outside the motor, but won't spark when it is under compression inside the motor
    shaddy likes this.
  7. HeadSmess

    HeadSmess Well-Known Member

    start at the beginning, and work to the end....

    remove the carb. pour a dash of fuel down the intake.

    you said it has spark. so, now, try starting it. without the carb.

    if it fires up, revs briefly, then dies... the CARB is the issue. clean it out.

    if it does what its already doing, not have an IGNITION issue.

    try a new plug first. anything but its chinese thing.

    the magneto issue is RARE. but here goes...

    remove the one nut holding the magnet onto the crankshaft, and hopefully it will just slide off with some fiddling. mark the side that was on the outside, flip it so its in, ensure key is in slot, and slide back on shaft...
    shaddy likes this.
  8. jaguar

    jaguar Well-Known Member

    you can hold the magneto with channel locks and then unscrew the nut holding it on.
    then pull it off, flip it around so that the previously external side is now the internal side.
    have fun getting it in place with the woodruff key! (you are going to hate me!)
    shaddy likes this.
  9. HeadSmess

    HeadSmess Well-Known Member

    someone really oughta pop off their cover and look at the key, and just remind ALL of us, which way the magnet points when the key is at 12o'clock :)
    shaddy likes this.
  10. shaddy

    shaddy New Member

    its finally run
    the problem is some inclination of the motor and the carb , its goes little pet down from the front , so i release the mounting bolts and i adjust it , and it finally run ,
    note : i flip the magneto and now i connect the blue wire for the cdi to the black wire of the magneto and it works without flip it again
    big thankssssssssssssss to jaguar-crassius - HeadSmess