No 1st start, dry spark plug, engine doesnt suck fuel, doesnt seem to "breathe" at all, at wits end...

SundayFlyboy97

New Member
Local time
1:55 AM
Joined
Apr 16, 2023
Messages
5
Location
Croatia
Hi everyone,

So like the title says I am at my wits end with this little Chinese 80cc 2 stroke kit.

I simply cant get it to 1st start.

Engine has spark, but it doesn't want to suck fuel. Spark plug is dry. Even if I spray fuel into the carb, or even in the cylinder itself, it doesn't start. Not even a putter, a pop. Nothing. Zilch.

I opened up the cylinder, carb, it all seems fine. Bowl is getting fuel, but it doesn't go past the carb. Compression is good. Fuel is good.



Does anyone have any idea why this engine won't start? Is it possible that ports are not milled correctly and that the engine has no capacity to move air around? It doesn't seem to breathe/circulate air at all.
 

darwin

Well-Known Member
Local time
5:55 PM
Joined
May 26, 2008
Messages
7,087
From everything stated in the OP, I wonder if the plug is grounding out. Key words are, sprayed fuel into the combustion chamber and nuttin. Compression being good it should have at least popped off.
 

Chainlube

Well-Known Member
Local time
4:55 PM
Joined
Jan 5, 2020
Messages
8,806
OK, let's determine if the timing on the motor is right. Pull the plug and put a straw down the spark plug hole. Turn the engine over until the straw is at its highest point. Then remove mag cover and take a picture of the end of the crank with the mag on it. Remove crank nut first so we can see position of mag on the crank. Then post picture here. TY
 
Top