Carby No acceleration when I pull the throttle, giving me a great amount of grief

Discussion in '2-Stroke Engines' started by Rafman, Aug 4, 2015.

  1. Rafman

    Rafman New Member


    I'm new here. I got my motored bike about a week ago, 2nd hand. When I accelerate it sounds like 40 chainsaws are being revved at the same time, so I decided to do some fiddling to see if I could get it quieter. Big mistake.

    I changed the rich/lean setting to leaner, but when I reattached the thing and tried to drive it I found that I had no acceleration, so whatever I did to it has messed it up.

    It will start fine but when I twist the throttle nothing happens. I've taken the throttle cable out and re-attached it several times but to no avail - still no acceleration. I wish I never went at it.

    I am certain I have put everything back the way it was, and I have even checked online tutorials about installing the throttle cable so I'm sure I have it in right.

    If anyone could give me some clue as to why the thing might not be accelerating I would appreciate it massively.


  2. crassius

    crassius Well-Known Member

    not knowing what kind of engine you have or what carb makes it difficult. but excessive noise can often be a head gasket coming loose
    Rafman likes this.
  3. Rafman

    Rafman New Member

    It is a two stroke engine, the very same engine and carb as I have seen on every motored bike video and picture online. And I don't care about the noise at all. I did, until this problem arose. If i got it driving again I wouldn't care if it sounds like a jet engine.
  4. crassius

    crassius Well-Known Member

    a common problem for new folks is when the c-clip that holds the slide needle is not put on tight & the needle falls all the way down into the main jet
    Rafman likes this.
  5. Rafman

    Rafman New Member

    I thought the needle was meant to go all the way down into the jet
  6. jeffuehrer

    jeffuehrer Member

    By setting the clip to a higher position (leaner) you also changed the tension on the cable which requires some adjustments of the throttle cable. Check for slack in the throttle cable. Fiddle with the adjustment screws on the cap of the carburetor until you notice a difference and adjust accordingly. On mine the top screw is about half way unscrewed.
    Rafman likes this.
  7. crassius

    crassius Well-Known Member

    Yes, but it's not supposed to stay there - the clip lets it come up when the slide comes up.
    Rafman likes this.
  8. Rafman

    Rafman New Member

    Well I just wanted to let everyone know that I fixed the problem, which was rooted in the carb pin slide thingymajig. The pin was not going back down into the jet when I released the throttle, the cause of which was slack in the cable; it was also fastened too tightly to the bike's main bar, via one of those small black plastic straps. So yeah, she runs well now, real well, apart from the loud pop pop pop noise of the engine, when I would like a nnnnnnnnnnnnnnnnnnnnnnnnn, if you catch my drift.

    But for now I'm a happy camper, having transport again, something to take me out of town. Thanks for all the help. You're ace.
  9. butre

    butre Well-Known Member

    it's a 2 stroke, it's going to be noisy.