Carby No fuel making it through NT carb

Discussion in '2-Stroke Engines' started by Zaqq, Sep 18, 2012.

  1. Zaqq

    Zaqq New Member

    After i have gotten most of the kinks worked out on my bike i still can't figure out how to work this carburetor. It is not letting fuel through even after I prime it. I have primed it to the point that it came out of the air filter but there isn't any getting into the tank.(I know you are not supposed to do that but I got carried away) I am getting a spark and the only thing that isn't working fully is the throttle(getting stuck halfway etc) If anyone has encountered this problem before then i would like a solution. Its probably something simple but i am a newbie. Thanks.

  2. flotsamm

    flotsamm New Member

    Maybe the float needle is stuck.. or the float is bad itself.
  3. scubaru89

    scubaru89 Member

    I just finished my first build today. I know when my NT carb arrived the throttle cylinder was stuck down in the carb, after getting it out I cleaned both the cylinder and the bore it fits into, make sure they line up and when its pushed down its not completely shutting off the intake channel.

    Have you watched the carb working off the engine by moving the throttle? Does the cylinder move freely, does it have a spot it gets stuck that you might be able to inspect?
  4. motorpsycho

    motorpsycho Active Member

    make sure that your throttle slide is in correctly.
    It can go in 2 different ways but only one way is correct.
    the slide has 2 slots in it (a long slot and a short slot).
    the long slot goes to the right side of the carb (when looking at it from above) and the slot has to line up with a pin that's on the side of the carb throat.
    the short slot goes to the left and lines up with the idle screw.
    if your throttle is sticking, you could have the slide in backwards.

    if you are getting fuel coming out of the rear of the carb when you prime it, then that tells you that there is fuel in the float bowl.
    it also tells you that your float is not stuck, and that fuek is making it up through the main jet.
    but, pull the float bowl off and make sure that the main jet hasn't fallen out.
    if the main jet has fallen out (which is common) your engine won't run because it'll be getting way too much fuel.
    it's also possible that the man jet is partially clogged with something.

    have you tried starting it using the choke?

    what do you mean that no fuel is getting into the "tank"?
    do you mean the float bowl on the bottom of the carb?
    if you have fuel coming out of the air filter, then there is fuel in the bowl.

    it might also be possible that you have a bad air leak where the carb bolts to the intake manifold, or at the threaded top cap of the carb where the throttle cable goes through.
    another thing to try is to remove the gas cap from the gas tank and try to start it.
    if your cap is not vented right, it will create a vacuum in the tank and will not allow fuel to flow.
    this is a long shot because it sounds like you have fuel in the carb, so it sounds like the fuel is flowing from the gas tank into the carb.
    these nt carbs are about as simple as they get so there's not a whole lot of things that can be wrong.
  5. Purple Haze

    Purple Haze Active Member

    A couple of quick tips that might help: First, if you over-tighten the cable housing on the carb, it can warp the bore that the slide moves in, causing binding. Second, remove the float bowl and check everything, make sure the jet is tight and the float pin is installed correctly. The quality control on these things is horrendous. I've had carbs with pins not installed, jets loose, stripped threads, etc. Double-check everything.Motorpsycho gave you some great advise, a faulty gas cap can cause many gremlins to pop up. One other thing, a poorly routed cable can bind, causing the throttle to stick. Hope this helps.
  6. Zaqq

    Zaqq New Member

    Thanks for the info guys. I'll give an update of it works.
  7. adrian101

    adrian101 Member

    go here, take the whole carb apart and put it back together. this thread should help.
  8. fm2200

    fm2200 Member

    I just had the same problem. Try doing this, their is a screw on the side of the fuel bowl, remove screw, let the fuel run out. If the fuel stops coming out it could be the brass nipple on the fuel inlet to the carb. My was slightly gummed up, run a small wire through it to clean it out.
  9. 101 Just told you what to do..If it stops flowing open it up turn on the air compressor and make sure to look right in there when cleaning(No.Don't do that)