Now it's the engine in general

Wtg78

Active Member
Local time
1:26 AM
Joined
Jan 28, 2024
Messages
114
Location
Mount Morris , NY 14510
So I got the phantom up and running and boy does she run... All the bolts right out of everything.. Lol.
So I'm having issues with my 2 cycle engine that it won't start. I've changed the cdi, magneto, the reed valve, and the plug. I've checked the head to make sure it wasn't getting low compression a d honed out the cylinder even and nothing. It's like it's not getting anything.. but I see gas coming and, so I'm confused at this point on what to do to make it run
Any clue out there?
 
So I got the phantom up and running and boy does she run... All the bolts right out of everything.. Lol.
So I'm having issues with my 2 cycle engine that it won't start. I've changed the cdi, magneto, the reed valve, and the plug. I've checked the head to make sure it wasn't getting low compression a d honed out the cylinder even and nothing. It's like it's not getting anything.. but I see gas coming and, so I'm confused at this point on what to do to make it run
Any clue out there?
Your sure its getting spark?
 
Is this issue with your phantom or something else?
My phantom 85.. I just can't get it to do anything but (lips together) brrrrbbbrrbbrrrbbrbb and nothing ... I posted a thread not to long ago on here and got some good feedback and it helped immensely. Hoping to get the same this go round too.
 
My phantom 85.. I just can't get it to do anything but (lips together) brrrrbbbrrbbrrrbbrbb and nothing ... I posted a thread not to long ago on here and got some good feedback and it helped immensely. Hoping to get the same this go round too.
Ok, thanks for the clarification. I suggest going over the baisics. Make sure your bolts are tight, and use blue loctite on everything other than the head bolts. Check for spark, check for fuel, check for compression, and make sure the head bolts are torqued to 144 inch pounds.

If you are havIng trouble with starting your clutch could also be slipping. Follow this guide to adjust it.
 
I have done all of these things except the torque of the head bolts but I'm pretty sure that's not it I've taken the carb and Reed valve and cleaned them also
 
I have done all of these things except the torque of the head bolts but I'm pretty sure that's not it
Those head bolts need to be retorqued each and EVERY heat cycle for the first 200 miles at a minimum.

It must be torqued to 144 inch pounds which is 12 foot pounds in an X pattern.

Retorque can only be done properly when motor is totally cold after its heat cycle is done.
 
Well I'm a dumb ass and didn't torque mine and the shook loose so I was on the go one day and they did it and I just super tightened them and stripped the hole.. That was before I knew how to re thread so I have different post in different holes but everything is definitely tight.. Is there a too tight?
 
Well I am at a stand still and have to go to work. No body make too much fun of me whole I'm gone.. Just help me figure out why this thing won't start
 
Back
Top