Carby Throttle cable won't let me go full revs

Discussion in '2-Stroke Engines' started by madguru100, Aug 3, 2015.

  1. madguru100

    madguru100 New Member

    Hi guys,
    So from the start when i fitted this kit it gave me problems with the throttle cable i used the adjusters but still nothing won't go full revs . So i thought the throttle cable is defective but i'm wrong cause i bought a new one but still the same problem . I have a video attached sorry about the lack of sound camera quality of phone is not that good . As you can see throttle will only go up to like 60 percent i tried adjusting the slack adjusters or what ever you call them and as you can see in one of the photos the cable hangs out . Can anyone enlighten me to what my problem is if tried near enough everything is this a problem to do with the butterfly valve or ? btw the photo with the slack i did put it in place while i was doing the video thanks

    Video :

    Attached Files:

  2. Leroybrown420

    Leroybrown420 Member

    Is the grip slipping on the throttle control? My old Critical was doing the same thing. I pulled off the grip, added a dab of rubber cement on the splines and that issue became a memory.
  3. madguru100

    madguru100 New Member

    Well i did drill a hole through the frame for the throttle control so i'm sure it's not slipping or do you mean the actual grip? thanks
  4. Leroybrown420

    Leroybrown420 Member

    Yes, the actual grip can and sometime will slip. The controller should be fixed into place with the set pin (the hole you had to drill). With mine it would open at 60% then the grip would slip. If I used my GI Joe Kung fu grip I could get full throttle. If that not the case it's an adjustment issue.

    Good luck!
  5. butre

    butre Well-Known Member

    my grip used to slip, I just put some super glue on it to fix that