Carby Tuning advice for Keihin carb

DieselTech

Well-Known Member
Local time
12:11 AM
Joined
Sep 18, 2021
Messages
4,521
Sweet thank you, if I use 2 of them my squish will be right in the optimal range. Thanks again for checking on that for me.
 

furweider691

Member
Local time
10:11 PM
Joined
Sep 7, 2020
Messages
98
Location
Fresno ,CA
So I got my engine running, and I've been messing with the carb tuning a bit. I believe I have a Keihin clone (see here). The bike seemed sluggish, so all I did was put the clip on the need up one (5 notches, from the middle one to one from the top). That helped. After this adjustment, I played with the idle mix and idle speed screws. The bike idles the highest when the mix screw is all the way in. Does this mean I need a bigger or smaller pilot jet? Or something else?
I have that same set up , the jet was a 70 , I rejected to a #68 . That solved my issues.
 

noah9988

Well-Known Member
Local time
1:11 AM
Joined
Jul 3, 2021
Messages
414
I have that same set up , the jet was a 70 , I rejected to a #68 . That solved my issues.
I'm at sea level and so far I got the best results with a 75 jet, clip one notch down from top. I currently have a 70 with the clip at the top but it's slower now. The engine is acting kinda funny and I'm getting a new head for it and I'm going to set the squish correctly so I'm not going to mess with it for now.

I got a top speed of 46, which I'm really happy about. However, the idle is inconsistent and dies sometimes. After I do one top speed run, it slows down considerably. The second run I got a top speed of 35 or something. It actually starts 4 stroking on the second time, and my plug gets black and wet. No idea why but I'm not going to do anything about it for now.
 

furweider691

Member
Local time
10:11 PM
Joined
Sep 7, 2020
Messages
98
Location
Fresno ,CA
I'm at sea level and so far I got the best results with a 75 jet, clip one notch down from top. I currently have a 70 with the clip at the top but it's slower now. The engine is acting kinda funny and I'm getting a new head for it and I'm going to set the squish correctly so I'm not going to mess with it for now.

I got a top speed of 46, which I'm really happy about. However, the idle is inconsistent and dies sometimes. After I do one top speed run, it slows down considerably. The second run I got a top speed of 35 or something. It actually starts 4 stroking on the second time, and my plug gets black and wet. No idea why but I'm not going to do anything about it for now.
I guess as long as it runs strong and ain't fouling plugs , run it .
 
Top