yd 100 idle problem😖😖😖help please

Benevolent ben

New Member
Local time
8:54 AM
Joined
Jan 31, 2022
Messages
1
Hello. so I have a fairly new yd100 I've been working on for quite a while. I cannot seem to get the thing to idle it either dies out like the idle screw is not enough in or if I screw it in anymore than that it will just run away or slowly get out of control.

I'm aware that the common problems with these are the intake manifold leaking. That could be so in this case but I have electrical tape wrapped around the entire manifold even where it joins to the cylinder. It may be still not air tight but is there any other known or common areas where the yd 100 will leak air ?

I've looked around the motor where the crankcase joins and there doesn't seem to be any gaps. Both the mesh intake filter in my inline filter have plenty of flow and are brand new.

My needle clip was on the second Notch down and I moved it numerous times in increments and it had no change. I also replace the carburetor with one from a known functioning motor and still the same problem. Also I am pretty sure my gas oil mix is correct, 32 to 1, but maybe that would affect it. I don't know.

So I'm thinking maybe even though I have electrical tape wrapped around the manifold it may still have a leak.

Any suggestions would be greatly appreciated as I've been struggling with this 4 months now I just can't get the thing to idle.

The way I ride is I just always try to feather the throttle to keep it running in a lot of times when I'm standing it's not idling I just let it die out.
I have once again a fairly new yd100 with CDH power expansion chamber, stock antique carburetor with stock manifold
thank you.
 

Karl Snarl

Well-Known Member
Local time
7:54 AM
Joined
Sep 20, 2019
Messages
5,822
Location
Chunky Monkey Mole Hole
You have an air leak, probably the carb neck or the intake where it meets the jug.

Did you tune the carb when you put the chamber on? you could be lean on the carb side if you didnt.
 
Top