Whizzer Throttle WC-1 1999

Discussion in 'Whizzer Motorized Bicycles' started by bobthefish19, Aug 30, 2013.

  1. bobthefish19

    bobthefish19 New Member

    My throttle seems to not be working correctly and causing it to die out. the cable does not seem to be broke. when I remove the top of the carb where the cable goes in it seems to be working fine. someone said to sand the slide but I am unsure. The Spring seems okay and it seems to seat okay in the carb. I cannot figure out how to remove the cable from the slide. all suggestions will help. email me with any photos or suggestions bob_the_fish19@yahoo.com thanks and happy holidays
     

  2. mason_man

    mason_man Active Member

    could the throttle valve be turned the wrong way, there is a small slot in the carb that the throttle valve is guided through. it's kinda hard to see without pics.
    was the bike running before?

    Ray
     
  3. bobthefish19

    bobthefish19 New Member

    I got the bike running for the first time last week. I fixed the throttle but it's missing a W clip unsure if it's necessary. When the bike started I'd seemed very fast but no control of the throttle. The bike is getting spark but doesn't want to turn over. I took apart the carb and cleaned all the jets. If it does start maybe a minute or two Max. I have been messing with the idle screw and air screw. I have the manual that says 1 to 1.5 turns out. The only thing I don't get are the two vacuum hoses on the carb that don't have any hoses attached. Does the cranckcase breather need to be attached to the air cleaner?
     
  4. mason_man

    mason_man Active Member

    Hi bobthefish19, the W clip holds the jet needle down in place, so when the throttle valve goes up or down it slides up and down with it, it's loose in between the spring.
    you defiantly need this. can call Whizzer U.S.A.877-944-9937 ask for part #4
    http://whizzermotorbike.catalog.com/browseGroup.cfm?item_group_id=48788
    or if you PM me your address i can send you one.

    Ray
     
  5. bobthefish19

    bobthefish19 New Member

    just sent you a PM
     
  6. mason_man

    mason_man Active Member

    Hi Bobby, i'll post pics of the carb and the w clip, let me know if theres more than just the w clip missing.
    you can also remove the restrictor from the carb if it already hasn't been. removing the muffler will also help too, loud tho. i also have a 99 too, with a few mods.
    Keep us posted of your progess, and if you need more info let us know.

    Ray
     

    Attached Files:

  7. bobthefish19

    bobthefish19 New Member

    Your a good man and great looking bike!! so for the restrictor remove those two black gaskets that are between the carb and cylinder? Or that cylinder? sorry don't know the correct words. can you post some pictures of the vacuum lines that come off the carb...if they attach to something to just empty into the air?
     
  8. mason_man

    mason_man Active Member

    Yes that cylinder in the intake port, see pics.the carb lines don't attach to anything. i post some pics of what i have,hope you can see. w clip in the mail!

    Ray
     

    Attached Files:

  9. bobthefish19

    bobthefish19 New Member

    thanks again I hope to have her running by next weekend!!!! ill send pics.....I traded a Nintendo Wii for the whizzer a few months ago and it didn't run. new spark plug and wire is all I really needed to purchase and this damn W clip...lol thanks again
     
  10. bobthefish19

    bobthefish19 New Member

    OOO btw should I run the basic spark plug or one of those iridium plugs?
     
  11. mason_man

    mason_man Active Member

    The Nintendo Wii... My Grandkids would have hung me! Lucky!!
    Both plugs are good.

    Ray
     
  12. mason_man

    mason_man Active Member

    Gonna add these pics too.

    Ray
     

    Attached Files:

  13. bobthefish19

    bobthefish19 New Member

    I hope the clip comes tomorrow to I can try and ride this weekend!!! no rain thank god
     
  14. mason_man

    mason_man Active Member

    mailed it out last monday, was a holiday tho. hopefully tomorrow you'll have it.
    when you can post some pics.

    Ray
     
  15. bobthefish19

    bobthefish19 New Member

    Still no clip. ..ugh
     
  16. Quenton Guenther

    Quenton Guenther Motored Bikes Sponsor

    Did you receive the clip yet?

    If not let us know and we will see you find one. The carburetor is common and many scooter or motorcycle shops should have them in stock [as they are commonly lost]. The carburetor is very similar to units used on small Honda motorcycle motors and parts are common.

    Have fun,
     
  17. mason_man

    mason_man Active Member

    PM sent.

    Ray
     
  18. bobthefish19

    bobthefish19 New Member

    Still not running. ..ugh..... starts up for about 30 seconds then dies. Any suggestions please
     
  19. Quenton Guenther

    Quenton Guenther Motored Bikes Sponsor

    Are you using the choke? If so, does it die when choke is off? Check fuel shut-off valve at tank to make sure the fuel is flowing well. Often paint chips from under the gas cap will stop up carburetor and or fuel shut-off at tank and fuel shut-off at carburetor.

    It is possible to have loose valve seats, however the motor normally runs longer before stopping [not always].

    Have fun,
     
  20. bobthefish19

    bobthefish19 New Member

    I have a new clean fuel line from tank to carb. Inside the tank is clear. I'm starting the bike with a drill bc peddling it and then walking it back home gets to be a pain. I took apart the carb and cleaned it everything was clear. It sounds like I'm flooding it when I give it a very little gas.
     
Loading...