power loss then a mess

Discussion in '2-Stroke Engines' started by RIOT, Aug 16, 2009.

  1. RIOT

    RIOT Member

    was out riding today, maybe went 4 miles and my power starts to come and go. i think its the choke getting lose again but its where it should be so i head home. when i get home i notice there is a big black oily mess on my bikes frame under the motor. any ideas guys?
     

  2. arceeguy

    arceeguy Active Member

    It could be something stuck in the float valve causing it to flood. Also, make sure that the float doesn't have fuel in it, causing it to sink. This will cause your mixture to go extremely rich, hinder performance, and leave an oily mess.
     
  3. Just_Gasit

    Just_Gasit Member

    Check your case gasket and that all the case bolts are still in place as well as head torque. If the oily mess isn't from the exhaust it must be something loose.
     
  4. graucho

    graucho Active Member

    Great feedback, RIOT are you running the breakin oil mixture still? Mine would blow oil underneath during breakin, then leave a quarter size drip under the exhaust when parked. It slowly got better then went away when It was OK to switch the oil mixture.___Or___ by chance is your mixture in your gas storage can incorrect?
     
    Last edited: Aug 18, 2009
  5. Hawaii_Ed

    Hawaii_Ed Member

    sounds like base gasket.
     
  6. RIOT

    RIOT Member

    i found the problem. the clamp holding the carb on was **** and the carb was popping off a hair while riding. just replaced the clamp. thank though guys
     
Loading...
Similar Threads -
  1. zippinaround
    Replies:
    17
    Views:
    176
  2. LeTweek

    Engine Trouble Power loss

    Replies:
    4
    Views:
    743
  3. rj1967
    Replies:
    10
    Views:
    795
  4. P3_Takuto
    Replies:
    9
    Views:
    993
  5. xboy23

    Engine Trouble Power loss

    Replies:
    7
    Views:
    1,410