New From Baltimore MD!!

Discussion in 'Introduce Yourself' started by areshwm, Jun 7, 2008.

  1. areshwm

    areshwm New Member

    Hello All!
    stumbled on this site while looking at bike motors. Great site! There is so much helpful information here i could almost get lost!!! anyhow i now have the 80cc chinese motor up and running on my old bike. Im fairly new to working with motors so this site can help me alot. the 2nd time i took the bike out riding she locked up and came to a stop i think it was the clutch because it was squealing a little bit. I have searched on here for hours but i donno where so start!! can some one point me to another thread that may help me get started on fixing my problem??:cry:
     

  2. graucho

    graucho Active Member

    Hi areshwn. Welcome to MBc!
    Maybe your chain was a little loose and it bunched up inside the small sproket cover. Remove the clutch arm cover and look. If not, since you got your intro out of the way repost in the Rack-Mount Drive_Train section. Keep in touch.

    If you search and are unable to find your answers, don't hesitate to post your question. Someone will steer you to a link, or reply to your question. Were here for each other! Enjoy! :grin:
    You may have seen this, but here's a great MBc starter "link" to get you motoring.
    http://www.motoredbikes.com/showthread.php?t=10392
     
  3. jared3377

    jared3377 Member

    Welcome!

    Sorry about your probs (especially on the second ride! :shock:). I'm sure any problems you have can be taken care of from the very cool folks on this site. Good luck with your repairs! :cool:
     
Loading...